Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

openerp.netsvc: permission denied for relation ir_module_module

By
CTT
on 10/17/13, 3:45 PM 10,060 views

Hi everybody !

Firstly, my database (in postgreSQL) belonged to openerp user. Then I changed the owner to another user (in my config file, /etc/openerp-server-hrm.conf). When I accessed after that, I have this error. Detail error in log file: " 2013-10-17 17:22:03,214 8912 ERROR hrm openerp.sql_db: Programming error: permission denied for relation ir_module_module , in query SELECT name, id, state, demo AS dbdemo, latest_version AS installed_version FROM ir_module_module WHERE name IN %s 2013-10-17 17:22:03,215 8912 ERROR hrm openerp.netsvc: permission denied for relation ir_module_module Traceback (most recent call last): File "/opt/openerp/openerp-hrm/openerp/openerp/netsvc.py", line 292, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/opt/openerp/openerp-hrm/openerp/openerp/service/web_services.py", line 433, in dispatch return fn(*params) File "/opt/openerp/openerp-hrm/openerp/openerp/service/web_services.py", line 444, in exp_authenticate res_users = pooler.get_pool(db).get('res.users') ..................................... ProgrammingError: permission denied for relation ir_module_module"

Many thanks!

6

The user using which you are trying to access the database may not be SUPERUSER access privileges.

So make sure that the user through which you are trying to login database must be SUPERUSER and if not then run following steps in terminal which will alter user into SUPERUSER:

1) psql template1 2) ALTER USER user_name WITH SUPERUSER; (user_name = The user by with you are going to restore the database. It gives SUPERUSER access privileges to user_name)

Hi Vijay, still i am facing the same problem is there any suggestions please give me.

babu
on 8/19/15, 5:08 AM
1
Suhas
On 3/26/16, 5:00 AM

I face same problem. I waste almost half day to resolve this problem, problem is there are two odoo server live and testing on same machine with different database user.In browser login to testing server and close the page and again try to login to live server from same browser and checking log. Odoo try to login testing database from live code base and same error raised. So just clear browser cache py pressing ctrl + shift + Del and delete everything, problem solved.

0
Carlos Contreras
On 8/5/16, 5:10 PM

Suhas it work for me your answer thankyou

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/17/13, 3:45 PM
Seen: 10060 times
Last updated: 8/5/16, 5:10 PM