Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

openerp.modules.module: Couldn't load module web

By
Pavel Pavlov
on 9/1/13, 10:30 AM 11,498 views

Hello,

I'm trying to follow doc.openerp.com/trunk/server/01_getting_started/ I installed fresh VM box with Debian and PostgreSQL 9.1, then did
1) apt-get install bzr
2) ssh-keygen –t rsa
3) bzr Launchpad-login <myid>
4) apt-get install python-psutil (on top of the packages in the list, because I was getting error that psutil could not be loaded on openerp server start. maybe should be added to the list in the docu?)
5) pavel@dev:~/openERP/v70/source$ pwd
/home/pavel/openERP/v70/source
6)pavel@dev:~/openERP/v70/source$ bzr cat -d lp:~openerp-dev/openerp-tools/trunk setup.sh | sh
7)root@dev:/home/pavel/openERP/projSrc# su - postgres -c "createuser -s pavel" (did this manually, because the "make db-setup" had problems on my debian, it didn't like the sudo in front of su in the script).
8)pavel@dev:~/openERP/v70/source$ make init-v70
bzr finished successfully with "Switched to branch: /home/pavel/openERP/v70/source/server/.bzr/branches/7.0/"
9) when I did make server I got two problems...

pavel@dev:~/openERP/v70/source$
make server
launch the server ./server/openerp-server --addons-path=addons,web/addons --log-level=debug ...
INFO ? openerp: OpenERP version 7.0
INFO ? openerp: > addons paths: /home/pavel/openERP/v70/source/addons,/home/pavel/openERP/v70/source/web/addons
...
CRITICAL ? openerp.modules.module: Couldn't load module web
CRITICAL ? openerp.modules.module: No module named unittest2
ERROR ? > openerp.service: Failed to load> server-wide module web.
web module is provided by the addons found in the openerp-web project.
Maybe you forgot to add those addons in your addons_path configuration.
Traceback (most recent call last):
File "/home/pavel/openERP/v70/source/server/openerp/service/__init__.py", line 60, in load_server_wide_modules
openerp.modules.module.load_openerp_module(m)
File "/home/pavel/openERP/v70/source/server/openerp/modules/module.py", line 405, in load_openerp_module
__import__('openerp.addons.' + module_name)
File "/home/pavel/openERP/v70/source/server/openerp/modules/module.py", > line 133, in load_module
mod = imp.load_module('openerp.addons.' +> module_part, f, path, descr)
File "/home/pavel/openERP/v70/source/web/addons/web/__init__.py", line 3, in <module>
import cli
File "/home/pavel/openERP/v70/source/web/addons/web/cli/__init__.py",> line 1, in <module>
import test_js File "/home/pavel/openERP/v70/source/web/addons/web/cli/test_js.py",
line 5, in <module>
import unittest2 ImportError: No module named unittest2

I was thinking that the problem is that web is missing in web/addons, but it's there...

pavel@dev:~/openERP/v70/source$ cd /home/pavel/openERP/v70/source/web/addons
pavel@dev:~/openERP/v70/source/web/addons$ ls -lrt
total 44
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:13 web_api
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:13 web_calendar
drwxr-xr-x 5 pavel pavel 4096 Sep  1 14:13 web_diagram
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:13 web_gantt
drwxr-xr-x 5 pavel pavel 4096 Sep  1 14:13 web_graph
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:13 web_hello
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:13 web_tests
drwxr-xr-x 3 pavel pavel 4096 Sep  1 14:13 web_tests_demo
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:13 web_view_editor
drwxr-xr-x 8 pavel pavel 4096 Sep  1 14:57 web
drwxr-xr-x 4 pavel pavel 4096 Sep  1 14:57 web_kanban

Has someone hit this issue before? I'm strugglin whole day to figure out what I've did wrong...

Regards, Pavel Pavlov

0
Pavel Pavlov
On 9/1/13, 1:28 PM

Hello,
I've solved the problem, thou I'm not really sure how...
While searching for the second problem(because I wasn't able to find any clue for the first one)...I've found in theopensourcerer.com/2012/12/how-to-install-openerp-7-0-on-ubuntu-12-04-lts/ ... there I found, that my second problem(unittest2) can be installed via apt-get (again not listed in the docu)...
So I just copy pasted the whole apt-get install from this website and I got

"The following NEW packages will be installed:
docutils-common docutils-doc python-docutils python-jinja2 python-mock python-pygments python-roman python-unittest2 python-zsi"

after that did again

pavel@dev:~/openERP/v70/source$ ./server/openerp-server --addons-path=addons,web/addons --log-level=debug

not sure why, but this time both it worked... now I have two questions
Q1: Should and how I report that some additioanl deps are not described in the apt-get install command in the guide?
Q2: Did I solve the missing web module, by installing unittest2 or something else happened?

Regards,
Pavel Pavlov

0

Thierry Godin

--Thierry Godin--
1516
| 8 7 8
Collegien, France
--Thierry Godin--

..

Thierry Godin
On 9/1/13, 6:47 PM

Hello,

Q1 : I don't know

Q2 : Yes, you solved the problem by installing unitest2 lib as writen in the log file

import unittest2 ImportError: No module named unittest2

Regards

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/1/13, 10:30 AM
Seen: 11498 times
Last updated: 3/16/15, 8:10 AM