Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

OpenERP apps unreachable

v7
By
More9ike
on 2/20/13, 2:26 PM 8,865 views

When I installed OpenERP 7 on my Ubuntu system and start the server, I could not see the modules. The system says OpenERP Apps unreachable showing locally available module.

You need to access this via localhost:8069. Please check the install script provided by thepopensourcer and look for openerp7 (google theopensourcer openerp7 install)

Gary
on 2/20/13, 3:07 PM

As already @MarcelLinke posted, check this previous question and its answer, it can be helpful for sure

Yaroslav
on 2/21/13, 9:05 AM
4
Ahmad Khayyat
On 2/25/13, 7:46 PM

The apps server is currently down.

apps.openerp.com

502 Bad Gateway
nginx/1.2.1
2
Marcel Linke
On 2/21/13, 8:19 AM

Hi,

maybe you forgot to configure the addon path:

sudo nano /etc/openerp-server.conf

Then look for the following line:

addons_path =

and insert the paths. Don't forget to chown the addon folders to openerp user.

Hope this helps...

You also could read the question "How to install OpenERP V7.0 on Ubuntu 12.04 from launchpad repository?" which describes the install and setup process. Sorry, I don't have permission to post links... The question was asked and answered yesterday...

This doesn't help at all on Windows server installation. I have the same issue now, all worked ok but suddenly got only "OpenERP Apps Unreachable" and "Showing locally available modules" now :(

Terje Uurtomies
on 2/25/13, 4:20 PM

I have the same problem. Yesterday It worked and showed the apps. Today "unreachable".

Frank
on 2/25/13, 4:49 PM

I have the same problem running V 7.0 (latest build) on ubuntu 12.04 server. It was working fine and now I am getting that message. Nothing has changed. I don't see that message in V 6.1.

FBA, Fred Blauer
on 2/25/13, 5:27 PM

I have a similar problem "OpenERP Apps Unreachable" and "Showing locally available modules"

Mark Lewis
on 2/26/13, 4:54 AM
0
Terje Uurtomies
On 2/25/13, 3:33 PM

This doesn't help at all on Windows server installation. I have the same issue now, all worked ok but suddenly got only "OpenERP Apps Unreachable" and "Showing locally available modules" now :(

Any ideas?

Please post this as comment, but not as answer!

Andreas Brueckl
on 2/25/13, 3:46 PM

This doesn't help at all on Windows server installation. I have the same issue now, all worked ok but suddenly got only "OpenERP Apps Unreachable" and "Showing locally available modules" now :(

Terje Uurtomies
on 2/25/13, 4:20 PM
0
Rex
On 2/26/13, 7:01 PM

In edit users/access rights Usability section you must check the Technical Features box in order to have access to the apps.

0
Aaron Neo
On 8/23/13, 7:26 AM

I am experiencing this similar problem too. My environment is Ubuntu 13.04, OpenERP 7.0 (installed from source). Using Firefox to access localhost:8069. After created a database, upon accessing the main page, the error dialog box appears "OpenERP apps unreachable".

Firewalls are all off. I can access apps.openerp.com from the very same Firefox browser so I am pretty sure its not a security problem.

Any advice? Any one?

Regards, Aaron

0

Andreas Brueckl

--Andreas Brueckl--
5056
| 7 8 7
Vienna, Austria
--Andreas Brueckl--
OpenERP Consulting and Development
Andreas Brueckl
On 2/25/13, 3:45 PM

I have the same problem with Windows 2008 Server. The problem is not related to OpenERP since the apps are reachable if I access from another PC.

I think that the problem is the Security Setting of your browser. The apps are loaded from a third party location (openerp.com) by using Cross-Site-Scripting (XSS) (see here). If you have very strict browser setting, then XSS is prohibited.

So I would try to enable XSS in your browser settings (see here).

Then I would try to add the OpenERP-Apps site to the outgoing firewall rules

is the app server down? https://apps.openerp.com/ 502 Bad Gateway nginx/1.2.1

Terje Uurtomies
on 2/25/13, 4:21 PM

Yes, i think so

Andreas Brueckl
on 2/25/13, 4:53 PM

I am using chrome, and I don't see that setting anywhere. I also tried in Firefox, and don't see that setting anywhere.

FBA, Fred Blauer
on 2/25/13, 5:30 PM

I would suggest to add the OpenERP-Apps site to the outgoing firewall rules

Andreas Brueckl
on 2/25/13, 5:38 PM

The only firewall I have is for the port, which is open.

FBA, Fred Blauer
on 2/25/13, 5:51 PM

The OpenERP-Apps site is Still Down! I need to do a demo tomorrow and will need to make sure to Not show the Settings Apps are because it will just popup the error.

GroupMiller, Gary Miller
on 2/26/13, 1:01 PM

The problem was fixed this morning. At least is has gone away with no changes here.

GroupMiller, Gary Miller
on 2/26/13, 2:35 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/20/13, 2:26 PM
Seen: 8865 times
Last updated: 3/16/15, 8:10 AM