Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

OpenERP 7 Windows installation through proxy : Module not found

By
Halbardier Philippe
on 7/10/13, 7:27 AM 5,802 views

I'm installing OpenERP 7.0 on a windows environment (Windows Seven) It works fine until i try to install my first app "Accounting & Finance", i've got the following message "Module not Found - The 'Account' module appears to be unavailable at the moment, please try again later"

I've wait and try again... same result Today i'm sure it's not due to OpenERP but to my company proxy. If i establish a network connection without any proxy, it works fine and immediately.

Did you have any installation doc. to explain which door need to be opened on the proxy, or other proxy setup to make ? Thank's

     Philippe

I would also like to know, how to setup OpenERP in order to install modules/apps through my corporate proxy. I am getting the same error messages as Philippe. Looking at the log and source code, it seems to be likely that the error is caused by a connection timeout due to missing proxy settings:

<code>

2013-10-28 08:07:02,042 276 ERROR ibo openerp.addons.base.module.module: Failed to fetch module base_setup Traceback (most recent call last): File "C:\Program Files (x86)\OpenERP 7.0\Server\server\openerp\addons\base\module\module.py", line 666, in install_from_urls </code>

Malte Jacobi
on 10/28/13, 5:31 AM
0
Nicolas
On 5/13/14, 8:49 AM

I have installed the openERP on my office computer OS: Win 7 64 bits. Register on a domain (ex: ASIA). My windowsId is therefore ASIA\Nicolas. In IE settings, we are not using the proxy settings, but instead the option [Use automatic configuration script] with a specific address.

But anytime i tried to download an app, I encounter following error: The base_setup module appears to be unavailable at the moment, please try again later.

FYI, I made the installation of openERP on a standalone computer Win7 64bits, without any domain, or proxy and everything is working fine.

I tried to add System variable http_proxy with our proxy address, but i did not manage to make it work Adding user/pwd also did not work (not sure about the syntax with a domain http_proxy=http://ASIA\Nicolas:password@proxy.thing.com:8080/

In the openerp-server.log, I get following message 2014-05-13 10:21:39,513 5620 INFO myNewCompany openerp.addons.base.module.module: Downloading module base_setup from OpenERP Apps 2014-05-13 10:21:39,605 5620 ERROR myNewCompany openerp.addons.base.module.module: Failed to fetch module base_setup Traceback (most recent call last): File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server\openerp\addons\base\module\module.py", line 647, in install_from_urls File "urllib2.pyc", line 126, in urlopen File "urllib2.pyc", line 391, in open File "urllib2.pyc", line 409, in _open File "urllib2.pyc", line 369, in _call_chain File "urllib2.pyc", line 1169, in https_open File "urllib2.pyc", line 1136, in do_open URLError: <urlopen error="" [errno="" 11004]="" getaddrinfo="" failed=""> 2014-05-13 10:21:39,608 5620 ERROR myNewCompany openerp.netsvc: Module not found The base_setup module appears to be unavailable at the moment, please try again later. Traceback (most recent call last): File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server.\openerp\netsvc.py", line 296, in dispatch_rpc File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server.\openerp\osv\osv.py", line 190, in execute_kw File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server.\openerp\osv\osv.py", line 132, in wrapper File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server.\openerp\osv\osv.py", line 199, in execute File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server.\openerp\osv\osv.py", line 187, in execute_cr File "C:\Program Files (x86)\OpenERP 7.0-20140511-231259\Server\server\openerp\addons\base\module\module.py", line 651, in install_from_urls except_osv: (u'Module not found', u'The base_setup module appears to be unavailable at the moment, please try again later.') 2014-05-13 10:21:39,624 5620 INFO myNewCompany werkzeug: 127.0.0.1 - - [13/May/2014 10:21:39] "POST /web/dataset/call_button HTTP/1.1" 200 -

0
David Camargo
On 2/10/14, 8:42 AM

Hi, I'm a new user and I'm installing OpenERP as a trial in my winwows enviroment. I had the same Error message.

So, my doubt is: Where should i insert the folowing comand ? http_proxy = my-proxy.local:port https_proxy = my-proxy.local:port

0
Ryno Meyer
On 7/7/14, 10:53 AM

Setting the environmental variables worked for me. Many thanks to @Malte Jacobi. And to @David, here is how you set the HTTP variables;

http://kaamka.blogspot.com/2009/06/httpproxy-environment-variable.html

Remember to set HTTPS as well:  https_proxy=https://username:password@proxy.example.org:8080

0
Malte Jacobi
On 10/28/13, 5:49 AM

Finally I figured it out. It's quite easy: You have to setup environment variables for the proxy. In my case I added the following two windows environment variables:

http_proxy = my-proxy.local:port
https_proxy = my-proxy.local:port

After adding the variables I restarted my OpenERP server and the module installation worked.

Cheers.

It did not work for me. Any alternative?

Nicolas
on 5/14/14, 12:33 AM
0

Ghanshyam Prajapati

--Ghanshyam Prajapati--
1377
| 4 4 8
Pune, India
--Ghanshyam Prajapati--
OpenERP Developer
Ghanshyam Prajapati
On 7/10/13, 7:33 AM

HI Try Following,

  • Settings >> Modules >> Modules.
  • Remove Installed module from search bar
  • Type Account and search it

Hope it work for you.

Hi, thank's but i can locate the app to be install ... the referenced problem occurs during the "loading process"

Halbardier Philippe
on 7/10/13, 7:41 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 7/10/13, 7:27 AM
Seen: 5802 times
Last updated: 3/16/15, 8:10 AM