Odoo Help

5

OpenERP 7: from localhost to fixed IP adress

By
Laurens
on 3/13/13, 6:32 AM 12,749 views

I installed OpenERP 7 on a Windows XP OS with the All-in-one setup. During the testing-phase I was running everything under localhost on my virtual machine. The databases are hosted under postgresql 9.2, and I can backup/restore using Pgadmin III without problems.

Now I want to assgign an IP adress to my databases and the server, so I can naviagate to the web client from a different machine in the network.

Most of the information I find is for linux distributions or older versions of OpenERP, and it's quite confusing. Thus far I've only been facing error messages when trying to make the necessary changes.

Could someone please tell me all the configuration files I need to edit under windows, so I don't miss any? The location of set file is good information, but if you would just tell me all the names of the config files, I would already be very grateful.

I have already editted the "openerp-server.conf" files under "C:\Program Files\OpenERP 7.0-20130305-002149\Server\server".

It now reads:

[options]
without_demo = False
unaccent = False
db_template = template1
db_password =openpgpwd
xmlrpcs = True
xmlrpcs_interface = 
syslog = False
logrotate = True
xmlrpcs_port = 8071
test_report_directory = False
list_db = True
timezone = False
xmlrpc_interface = 192.168.100.102
test_file = False
smtp_password = False
secure_pkey_file = server.pkey
xmlrpc_port = 8069
workers = 0
log_level = info
xmlrpc = True
admin_passwd = admin
smtp_port = 25
smtp_server = localhost
static_http_url_prefix = None
limit_request = 8192
test_commit = False
proxy_mode = False
demo = {}
dbfilter = .*
login_message = False
import_partial = 
pidfile = None
db_maxconn = 64
osv_memory_count_limit = False
reportgz = False
osv_memory_age_limit = 1.0
netrpc_port = 8070
db_port =5432
db_name = False
debug_mode = False
netrpc = False
limit_time_real = 120
limit_memory_hard = 805306368
logfile = C:\Program Files\OpenERP 7.0-20130305-002149\Server\server\openerp-server.log
csv_internal_sep = ,
limit_time_cpu = 60
pg_path =C:\Program Files\OpenERP 7.0-20130305-002149\PostgreSQL\bin
limit_memory_soft = 671088640
static_http_enable = False
translate_modules = ['all']
smtp_ssl = False
server_wide_modules = None
netrpc_interface = 
smtp_user = False
log_handler = [':INFO']
db_user =openpg
db_host = 192.168.100.102
test_enable = False
max_cron_threads = 2
static_http_document_root = None
email_from = False
addons_path = C:\Program Files\OpenERP 7.0-20130305-002149\Server\server\openerp\addons
secure_cert_file = server.cert

Is there anything else I need to edit in this file, or in another file?

I have since also gone through the "postgresql.conf", "pgpass.conf" and "pg_hba.conf" files, under the Openerp/Server/Postgresql/data folder; and editted any mention of localhost to "192.168.100.102". The ports I left unchanged.

Since then I have stopped and started the OpenERP Server process under services a few times, but as of now I can't reach my server through either adress. (localhost nor the fixed IP adress)

I'm not sure I'm going about this the right way, any feedback would be appreciated.

Laurens
on 3/13/13, 9:17 AM

I have fixed my problem some time ago, I found it best to start from a fresh install. Leave all settings default, and start editting network settings once the server is already up and running.

Laurens
on 4/8/13, 1:51 PM
1
Laurens
On 5/7/13, 12:48 PM

My problem was related to compatibility issues from a previous postgresql installation. I searched my registry for all postgresql and openerp related keys, deleted them all - and then reinstalled postgresql and openerp completly. After initial configuration I was able to recover most of my dump files, and have been running without major problems so far.

2

AJ Schrafel Paper Corp

--AJ Schrafel Paper Corp--
2120
| 4 5 8
Bronx, United States
--AJ Schrafel Paper Corp--

Exploring OpenERP for business

AJ Schrafel Paper Corp
On 3/13/13, 10:37 AM

If you can connect to your server from the local machine in a web browser pointed to localhost:8069 - Your problem is probably with windows firewall.

This Microsoft article gives some good details on how to open up a port in windows firewall - http://support.microsoft.com/kb/308127

0
Jonathan Leaders
On 2/16/17, 12:29 PM

Configure Odoo

This is for 10, but will work for all versions

In C:\Program Files (x86)\Odoo 10.0\server

change (where your IP is 192.168.1.17 -- update accordingly)

db_host = localhost

to

db_host = 192.168.1.17


Configure PostgreSQL

In C:\Program Files (x86)\Odoo 10.0\PostgreSQL\data\pg_hba.conf

Add the following line

host    all             all             192.168.1.17/24            md5


Restart Server

Go to Windows Services and restart the following services:

  • odoo-server-10.0 10.0

  • PostgreSQL_For_Odoo - PostgreSQL Server 9.5

Test Firewall

go to http://192.168.1.17/ on your local device. It should work.

Then try on an external device on the internal network. If it fails on the external device, disable windows firewall and try again. If it works, then add an exception for C:\Program Files (x86)\Odoo 10.0\server\odoo-bin.exe

0
akma72
On 3/18/13, 3:07 AM

I have the same problem on a W7, I completely disabled the firewall and does not work :(, any ideas?

this config file Laurens touched, what did he change exactly?

Thanks, Akma

Do not change anything in the config files, that is completely unnecessary. The first thing you need to confirm is that you can access your openerp install by navigating to localhost:8069 - if you can do that then openerp does not need to be touched - it is a problem with your settings in windows

AJ Schrafel Paper Corp
on 3/18/13, 2:00 PM

actually, changing "localhost" for the IP of the server in 2 places in that config file, fixed the problem :)

akma72
on 3/18/13, 7:40 PM

Indeed, I changed the host in the config file. Don't forget to check the postgresql config files from your Pgadmin client. Important to note is that you need to format the host as IP / subnetmask. For instance: 192.168.xxx.xxx/24.

Laurens
on 3/19/13, 10:19 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

4 follower(s)

Stats

Asked: 3/13/13, 6:32 AM
Seen: 12749 times
Last updated: 2/16/17, 12:29 PM