Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Open ERP 7 : Run Scheduler Not Creating Purchase requests

By
Sudheendra Walvekar
on 2/10/13, 8:07 AM 7,596 views

Hi All, I have created a bill of material having two products under it. After I create a Sales order I see that a manufacturing order is created. I have not created minimum order quantity while creating the products.

I ran the scheduler.But I see that there are no purchase requests created, though I have created supplier, quantity and the cost for the product.

I would appreciate any help

Regards

0
Gustavo
On 2/10/13, 5:31 PM

You should set the product minimum and maximum order point, and run the scheduler again. That should take care of your problem.

As you may be aware the scheduler has a check box for automatic order point which should take care the min and max order point. For your information, this is working well with DB with demonstration data and creates procurement request automatically. I hope to receive few more suggestions

Prime Minds Consultancy Services, Sudheendra Walvekar
on 2/15/13, 7:08 AM
1
Hemang Rindani
On 11/26/13, 8:34 AM

Hello all, I defined the reordering rule, i too defined the supplier in the product form. now, when i clicked run scheduler, an exception is generated, which shows that it is in Running stage with no reason mentioned. I cannot see any auto PR generated during this scenario. I am confused as why the PR is not generated. is there any solution for this! Am i doing something wrong? can you please help me to figure this out?

Appriciate your help Regards

I've the same situation :s

Qamar Soft
on 9/19/14, 5:30 AM
0

Naresh Soni (nch)

--Naresh Soni (nch)--
Tiny ERP Pvt Ltd
http://www.odoo.com
1281
| 2 2 4
India
--Naresh Soni (nch)--

Team Lead, Odoo(Formerly OpenERP) Support & OPW

Naresh Soni (nch)
On 2/10/13, 12:54 PM

You should check your procurement's that are created for your products. You can easily know why your purchase order was not created.The procurement will be in exception state just view it in form view and check the reason field.

As you may be aware the scheduler has a check box for automatic order point which should take care the min and max order point. For your information, this is working well with DB with demonstration data and creates procurement request automatically. I hope to receive few more suggestions

Prime Minds Consultancy Services, Sudheendra Walvekar
on 2/15/13, 7:30 AM

The scheduler does not create purchase request, but instead it creates a draft purchase order. Purchase Order and Purchase Request are two different documents in OpenERP

Aldennis
on 2/25/14, 10:07 AM

Thank you. I had figured out the issue. Scheduler was incorrectly setup which I corrected. I now see that the scheduler is now creating entry under Purchase->Purchase Requisitions with the status as New. When I open the entry I see two buttons 'Send to Suppliers' on top of the form and 'Request a quotation' at the bottom. 'Send to suppliers' would send a request for quotation to the suppliers and 'Request to quotation' button is creating an entry under Purchase->Quotations which is a draft PO. It is not creating a Draft PO directly when I run the scheduler. Am I missing something?

Prime Minds Consultancy Services, Sudheendra Walvekar
on 2/25/14, 11:43 AM

dear suheendra, i have exactly the same issue - wondering how you solved it? i do not want to set minimum and maximum order rules - it worked before with setting them to 0 - suddenly it won't work anymore - any hints and tips are greatly appreciated!

patrick cadonau
on 5/13/14, 2:22 PM
0
Sudheendra Walvekar
On 2/10/13, 1:47 PM

Thank you very Much for your response. I navigated to procurement exceptions and I see the Error as ' Not enough stock and no minimum orderpoint rule defined'. Since the quantity is zero, the scheduler run is expected to create a purchase request. This is not happening. I would appreciate if you can provide further guidance. Regards

set the minimum and maximum order point and run the procurement / schedular again.

Naresh Soni (nch)
on 2/11/13, 3:22 AM

As you may be aware the scheduler has a check box for automatic order point which should take care the min and max order point. For your information, this is working well with DB with demonstration data and creates procurement request automatically. I hope to receive few more suggestions

Prime Minds Consultancy Services, Sudheendra Walvekar
on 2/15/13, 7:15 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 2/10/13, 8:07 AM
Seen: 7596 times
Last updated: 3/16/15, 8:10 AM