Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Oops! Google Chrome could not connect to localhost:8069 - Fixed

By
Ruben
on 7/26/13, 3:21 PM 7,418 views

Issue Fixed

The issue has been fixed, by uninstalling database and openerp and installing them back again. Thanks to OpenERP team.

Hello everyone,

I am not able to access openerp server after completing the installation. Find the details below.

Installed

  1. PostgreSQL 9.2.4
  2. phpPgAdmin (can connect to database just fine)
  3. Python 2.7.3 (added path)
  4. Installed OpenERP Server 7.0 (can locate under ProgramFiles)

Additionally, installed (for other purpose)

  1. PHP
  2. Apache

How to debug? I'm on Win7 x86.. As you can guess, I'm new to this part of the world. Please help!

Update:

  1. I turned the Firewall off.
  2. set the pg_path in conf file to C:\Program Files\PostgreSQL\9.2\bin
  3. Tried in Firefox

Still, not resolved.

Update 1:

I manually started the openerp server from services.msc and saw that it was stopped automatically with the message "Some services stop automatically if they are not in use by any other services or programs". What could be the possible root cause?

1

AJ Schrafel Paper Corp

--AJ Schrafel Paper Corp--
2050
| 4 5 8
Bronx, United States
--AJ Schrafel Paper Corp--

Exploring OpenERP for business

AJ Schrafel Paper Corp
On 7/27/13, 1:36 PM

First make sure a firewall on the machine is not blocking the port 8069. Google windows firewall for detailed instructions on how to open a port.

It is probably a windows firewall problem and opening the port will fix it. If not continue on.

Open a command prompt on the windows server with openERP. Type netstat -tulpn

You should see the open port for openERP in the list of ports. If you see another program at port 8069 that program is blocking openERP and must be disabled. If you don't see a program at port 8069 the something is preventing openerp from starting check the server log

If you see openerp running at port 8069 then type telnet 127.0.0.1 8069

And you should get a response of some sort. If you don't get a response, there is something on your windows machine blocking programs from connecting to that port. See step one

IMHO you would be better off buying a cheap refurbished pc install Ubuntu and testing openERP on that rather than trying to test openERP on a windows machine that is clearly serving other purposes.

I opened the port. I turned the firewall and anti-virus off without any success. Is there anyway to check if openerp server is running? p.s: this a temporary set up for training. I'll soon migrate to ubuntu on my desktop PC.

Ruben
on 7/27/13, 5:47 PM

I manually started the openerp server from services.msc and saw that it was stopped automatically with the message "Some services stop automatically if they are not in use by any other services or programs". What could be the possible root cause?

Ruben
on 7/27/13, 6:10 PM
0

Daniel Reis

--Daniel Reis--
3436
| 6 7 9
Lisbon, Portugal
--Daniel Reis--

Author of the "Odoo Development Essentials" book.

Applications Manager at Securitas Portugal

Github: https://github.com/dreispt

Twitter; @reis_pt


Daniel Reis
On 7/26/13, 6:14 PM

Read the server log. It will tell you why the server didn't start.

Where is it located? Program Files\OpennERP\Server? The log file \server\openerp-server.log doesn't have any useful info. It has only database user info

Ruben
on 7/27/13, 2:22 AM
0
Ruben
On 7/29/13, 3:09 PM

Nevermind. I fixed the problem by reinstalling OpenERP and PGSQL..

0

Gustavo

--Gustavo--
950
| 2 1 4
Buenos Aires, Argentina
--Gustavo--

Python developer, big fan of sailing

Gustavo
On 7/26/13, 5:31 PM

There are many things you can check, some things that come to my mind are:

a) connecting with Firefox instead of Chrome b) checking whether the server is running c) checking whether the 8069 port is open d) check whether a firewall is blocking port 8069

I guess I should go with the option (b). How do I ensure the server is running? Or How do I start the server. I have no firefox or browser problems since my phppgadmin and apache are loading just fine on chrome..

Update: I ran openerp-server.exe. But, I still have the same problem..

Ruben
on 7/27/13, 2:20 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/26/13, 3:21 PM
Seen: 7418 times
Last updated: 3/16/15, 8:10 AM