Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

ooor, impossible to run.

By
dominix
on 3/17/14, 5:41 PM 970 views

the gem install correctly but from gem or from github I got always the same error: (I've tryed ruby 1.9.1 then 1.9.3 then 2.0.0 no dependency probleme but always same error ) NB : username, password, database and port are correct !

1) Ooor Configure existing database should be able to load a profile Failure/Error: @ooor = Ooor.new(:url => @url, :username => @username, :password => @password, :database => @database) NoMethodError: undefined method split' for nil:NilClass # ./lib/ooor/services.rb:46:inlogin' # ./lib/ooor/services.rb:85:in object_service' # ./lib/ooor/session.rb:63:inload_models' # ./lib/ooor/session.rb:31:in global_login' # ./lib/ooor.rb:59:innew' # ./spec/ooor_spec.rb:41:in `block (3 levels) in <top (required)>'<="" p="">

Where does this error occur?

Jaakko Komulainen
on 3/18/14, 10:21 AM

when I run ooor, when I try to install ooor using rake (the testing part)

dominix
on 3/18/14, 5:25 PM

from the command line I got this : * OOOR - OpenObject on Ruby! Published under the MIT license by http://Akretion.com * D, [2014-03-18T10:23:40.144910 #30347] DEBUG -- : OOOR login - db: infomic, username: micropol /var/lib/gems/2.0.0/gems/ooor-2.0.3/lib/ooor/services.rb:46:in login': undefined methodsplit' for nil:NilClass (NoMethodError) from /var/lib/gems/2.0.0/gems/ooor-2.0.3/lib/ooor/services.rb:85:in object_service' from /var/lib/gems/2.0.0/gems/ooor-2.0.3/lib/ooor/session.rb:63:inload_models' from /var/lib/gems/2.0.0/gems/ooor-2.0.3/lib/ooor/session.rb:31:in `global_login' from

dominix
on 3/18/14, 5:25 PM
0
dominix
On 3/31/14, 10:37 PM

The raison is : ooor v 2.0.3 only run on Openerp V 6/7/8 for OpenERP V 5 ooor version 1.9.2 is required.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/17/14, 5:41 PM
Seen: 970 times
Last updated: 3/16/15, 8:10 AM