Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


[Oodo 9] currency_rate_update not working

Mike Greenish
on 10/14/16, 6:28 AM 83 views

I have installed the currency_rate_update module on my server.  I have set it up to run once a day with data from the ECB.  I have set CHF, CAD, USD as active and they are active under Accounting->Multiple Currencies.  

I can see in the logs that the module runs as scheduled:

2016-10-14 10:20:22,473 29184 INFO addhaptics_odoo9_test openerp.addons.currency_rate_update.model.currency_rate_update: Starting the currency rate update cron2016-10-14 10:20:22,474 29184 INFO addhaptics_odoo9_test openerp.addons.currency_rate_update.model.currency_rate_update: End of the currency rate update cron

But when I look at the exchange rates, they are still set to 1 under Accounting->Multiple Currencies->Currencies.  Have I missed something?

On 10/14/16, 10:21 AM

Have you ticked 'Automatick update' on the page 'Currency update configuration' for your company?

By the way I dislike this module because it update rates for the day it starts but not the day in the ECB file and the 'update now' button depends on 'Automatick update' checkbox that, as for me, is wrong.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 10/14/16, 6:28 AM
Seen: 83 times
Last updated: 10/14/16, 10:21 AM