Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Odoo9 Web module issues

By
Ruban Kannan
on 2/23/16, 4:13 PM 1,073 views

Hi I get the following error when I load the web module in Odoo9. Please help me fix it. 

Could not get content for /web/static/src/less/navbar.less defined in bundle 'website.assets_frontend'.
Could not get content for /web/static/src/less/app_switcher.less defined in bundle 'website.assets_frontend'.
Could not get content for /web/static/src/less/app_switcher_layout.less defined in bundle 'website.assets_frontend'.

I have this problem only with some modules like website_enterprise or customer references and so on.. What exactly do I need to do to avoid these problems other than uninstalling the affecting modules

A or B or C Technologies Pvt LTD
on 2/24/16, 10:51 AM
1
Ankit Gauri
On 2/24/16, 1:03 AM

Hello Ruban

may be if i m not wrong you trying to install website or load website theme  so i think you have to try to put all this less css inside your template hope it works for you

Thank you

I dont get it. I have this problem only when I install the website enterprise module. It is fine if I uninstall website enterprise module.. https://github.com/odoo/enterprise/tree/9.0/website_enterprise

A or B or C Technologies Pvt LTD
on 2/24/16, 10:49 AM
1
Divya-browseinfo
On 2/24/16, 1:12 AM

hello,

you have to install this packages...

sudo apt-get update

sudo apt-get install nodejs

sudo apt-get install npm

sudo apt-get install -y nodejs

sudo npm install -g npm  

sudo npm install -g less less-plugin-clean-css


Reference:

https://www.odoo.com/forum/help-1/question/ubuntu-server-14-04-howto-install-nodejs-npm-and-less-82575


I have them installed already. I guess it's the problem with some of the web modules only. I get this problem, when I install the enterprise's module website enterprise

A or B or C Technologies Pvt LTD
on 2/24/16, 10:37 AM
0
David Bertha
On 9/7/16, 6:55 AM

Hi Ruban,

web module is defined in community addons AND in enterprise addons. Enterprise addons path should be given before community addons because odoo will take the first patch that match to the module name. The community web module doesn't have those files but the enterprise one does

0
Vivekrajan
On 3/9/16, 1:05 AM

Hi Ruban,

You might have two different databases. community and enterprise version. So when you start the community odoo instance, try to use --db-filter community-database-name  and vice versa.


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/23/16, 4:13 PM
Seen: 1073 times
Last updated: 9/7/16, 6:55 AM