Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Odoo9 database backup error

By
radzhang
on 1/27/16, 6:16 AM 1,045 views

when i use http://localhost:8069/web/database/manager and want to backup the database,an error happened like this

2016-01-27 15:44:41,303 76936 ERROR ? openerp.addons.web.controllers.main: Database.backup

Traceback (most recent call last):

  File "D:\git\odoo9\addons\web\controllers\main.py", line 693, in backup

    ('Content-Disposition', content_disposition(filename)),

  File "D:\git\odoo9\addons\web\controllers\main.py", line 422, in content_disposition

    return request.registry['ir.http'].content_disposition(filename)

TypeError: 'NoneType' object has no attribute '__getitem__'

2016-01-27 15:44:41,839 76936 INFO ? werkzeug: 127.0.0.1 - - [27/Jan/2016 15:44:41] "POST /web/database/backup HTTP/1.1" 200 -

3
Marius Stedjan
On 4/1/16, 7:35 AM

Did you get it fixed?

I also had this problem. 
I fixed it by logging in with the admin user first, and then going to /web/database/manager and doing the backup.

Can't say I've had this problem before, so I don't know the reason for suddenly having to log in.

Thanks, I fixed it.

Regards,

FTK

TK Fontaine
on 6/13/16, 7:32 AM
0
Dilip Dabhi
On 6/30/16, 1:14 AM

Also you can backup database from terminal by following commands :

-> sudo su postgres

-> psql -l     (  it will display database list )

-> pg_dump database_name > /tmp/backup_database.sql


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 1/27/16, 6:16 AM
Seen: 1045 times
Last updated: 6/30/16, 1:14 AM