Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo8 custom module installation

on 10/18/14, 1:29 PM 1,339 views


ok after I have been trying to understand odoo 8 i am finally giving up. I tried to install a simple module, basically this module does nothin i just wanted to check if the process of installing a module is the same as it used to be in openerp v7. I added my module to the addon path, restarted odoo and, as it used to be, I updated the module list and was hoping to find my module. However, I tried it several times makeing sure the folder permission are correc etc. nothing helped...the module was just not available, I could not find it. Checking if it might be my code I took a few modules from v7 and added them to the addon path. None of the module are showing after updating the list. The logfile shows no error or anyhting suspicious. What changed to opener v7? do i have to add anything special in the descriptor files to make odoo 8 to find these modules? Are there such tremendous changes that modules from openerp v7 are so hard to adapt? A great part of the charme of openERP was the incredible amount of available modules. I would have assumed that compatibility to v7 module would have been a key objective for odoo 8.0 or is this part of the new concept to close odoo step-by-step to sell plans to customers?

Thanks for any information!


@Peter Schenkel, Were you trying to install a version 7.0 module in a version 8.0 Odoo instance? If so the database schema has changed significantly to allow for greater functionality and flexibility in version 8.0. I suggest you just do a complete reinstall. Also double check if you are starting the server with the configuration file mentioned in your openerp-server.conf or odoo-server.conf. It should be ./openerp-server -c /etc/openerp-server.conf or similar. If you want to try an install script you can run this: wget https://raw.githubusercontent.com/lukebranch/odoo-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh sudo sh odoo_install.sh however this must be done on a fresh install of Ubuntu 12.04 or 14.04 with no extras installed (ie. a clean install of the OS). Feel free to post back if you have any issues.

Luke Branch
on 10/18/14, 9:48 PM
On 10/19/14, 3:20 AM

Thanks for your answer. However I already have an instance of odoo perfectly running on my server. the problem is that except the 270 pre-installed modules I cannot get any other modules to be recognized by odoo even though I added the directory to the path. I tried it with a very simple module which just adds a field to the Res.partner object. If odoo is not going to a stable foundation interface which is update invariant I foresee massive negative impact on the ecosystem which I would regret.

On 10/18/14, 11:24 PM

Try stoping OpenERP service, and launch the daemon whit

openerp-server -u -d --addons-path=/your/addons/path/

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 10/18/14, 1:29 PM
Seen: 1339 times
Last updated: 3/16/15, 8:10 AM