Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Odoo v8 no start

By
dfsgfdsgdsf
on 6/27/14, 2:59 PM 1,076 views

After installing odoo and run this command

./openerp-server -c /etc/openerp-server.conf & 

and go to http://........:8069

I have this message : 

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application

there my error

tail -f /var/log/openerp/openerp-server.log

    return Cursor(self.__pool, self.dbname, serialized=serialized)
  File "/opt/odoo/v8/server/openerp/sql_db.py", line 177, in __init__
    self._cnx = pool.borrow(dsn(dbname))
  File "/opt/odoo/v8/server/openerp/sql_db.py", line 439, in _locked
    return fun(self, *args, **kwargs)
  File "/opt/odoo/v8/server/openerp/sql_db.py", line 502, in borrow
    result = psycopg2.connect(dsn=dsn, connection_factory=PsycoConnection)
  File "/usr/share/pyshared/psycopg2/__init__.py", line 179, in connect
    connection_factory=connection_factory, async=async)
OperationalError: fe_sendauth: no password supplied

Thank you

oitsuki

 

I had the same problem and here is the solution. Create an openerp-server.conf file in the project directory, and copy paste this content. [options] ; This is the password that allows database operations: ; admin_passwd = admin db_host = False db_port = False db_user = openpg db_password = openpgpwd addons_path = "your addons path" for exemple C:\Users\hp-pc\workspace\openerp-8.0-9d5fb65\openerp\addons start again your server and that's it.

Mehdi
on 10/23/14, 4:30 AM
0

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 6/27/14, 4:15 PM

I guess you didn't add database password information in openerp-server.conf file.

Add "db_password = your_db_password" in conf file.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 6/27/14, 2:59 PM
Seen: 1076 times
Last updated: 3/16/15, 8:10 AM