Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Odoo V8 Install On Centos Error: start-stop-daemon: command not found

By
Andrew Trueman
on 9/25/14, 8:11 AM 6,603 views

Hi Everyone,

Apologies for the long post in advance but I have spent a whole week on this so want to outline what has happened in as much detail as possible in the hope someone will be able to pinpoint a solution for me.

First the system. I am running Centos 6.5 on a VPS. Python 2.6.6.

I have researched the installation of Openerp 7 extensively and with a bit of editing cobbled together an install script which works perfectly. Takes just a fewminutes to get a fully working Openerp 7 installation up and running.

I was hoping the same script with a few modifications would be able to install Odoo V8. Not the case. To cut a long story short it appears I need Python 2.7 installed. I'm unable to uninstall Python 2.6 as this will break Yum and who knows what else. I have painstakingly followed the instructions from various sites to install Python 2.7 so it runs in parallel with Python 2.6. This seems to have been successful.

I have also followed many variations of instructions and scripts to install Odoo V8 on Centos. They are usually variations on the V7 scripts so do not take account of the requirement for Python 2.7. None of them work. Even if the installation goes cleanly (after I have installed Python 2.7), I can never get the server started. There are always errors about missing files. Sorry to be non specific but as you will see I have settled on an installation process which is simple and fast.

I have discovered that, rather than messing about making Python myself, Centos have The Software Collections ( SCL ) Repository which is a one click install. Perfect thought I. So I have written my own script (see below) which works perfectly. No errors. I have also used the Odoo RPM package to install which again works perfectly (once all the dependencies have been installed).

Now my problem. When running the server with 'service openerp start' nothing happens. No error. No output. Nothing. Having researched a bit further it seems the script /etc/init.d/openerp is pointing to the wrong location for the daemon as follows:

DAEMON=/usr/bin/openerp-server

The opernerp-server file is not there. It is actually in the location below, so I have edited the script to add 'local' to the path as follows:

DAEMON=/usr/local/bin/openerp-server

Now 'service openerp start' runs but gives an error:

Starting openerp: /etc/init.d/openerp: line 28: start-stop-daemon: command not found

If I try and run openerp-server to start the server manually I get the following error:

Traceback (most recent call last):
  File "/usr/local/bin/openerp-server", line 2, in <module>
    import openerp
ImportError: No module named openerp

If I run python /usr/local/bin/odoo.py I get the following error:

Traceback (most recent call last):
  File "/usr/local/bin/odoo.py", line 162, in <module>
    main()
  File "/usr/local/bin/odoo.py", line 158, in main
    import openerp
ImportError: No module named openerp

 

So it looks like the module openerp can't be found. Having a quick hunt around using find -name openerp reveals it is probably this file:

/usr/local/lib/python2.7/dist-packages/openerp

Running this file manually using python /usr/local/lib/python2.7/dist-packages/openerp give another error:

 

can't find '__main__' module in '/usr/local/lib/python2.7/dist-packages/openerp'

 

Arghh! It seemed to be going so well! This is now where I am stuck. I am sure I am about a gnats whisker away from getting this to work. Can some help please? Many thanks in advance.

Here is the script I am using:

# Install and Update Required Repositories
yum -y update
yum -y install centos-release-SCL
rpm -ivh http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
rpm -ivh http://yum.pgrpms.org/9.3/redhat/rhel-6-x86_64/pgdg-centos93-9.3-1.noarch.rpm

# Install Python 2.7
yum -y install python27

# Install PostgreSQL9.3
yum -y install postgresql93-libs postgresql93-server postgresql93
service postgresql-9.3 initdb
chkconfig postgresql-9.3 on
service postgresql-9.3 start

# Create Postgresql User Allow External Pgadmin Access
su - postgres -c "createuser  --superuser openerp"
su - postgres -c "psql -U postgres -d postgres -c \"alter user postgres with password 'password';\""
echo "listen_addresses = '*'" >> /var/lib/pgsql/9.3/data/postgresql.conf
echo "host    all             all             0.0.0.0/0                 md5" >> /var/lib/pgsql/9.3/data/pg_hba.conf
service postgresql-9.3 stop
service postgresql-9.3 start

# Activate SCL
scl enable python27 bash

# Install Odoo Dependencies
yum -y install babel libxslt-python pyparsing python-dateutil python-decorator python-docutils python-feedparser python-imaging python-jinja2 python-ldap python-lxml python-mako python-mock python-openid python-passlib python-psutil python-psycopg2 python-reportlab python-requests python-simplejson python-unittest2 python-vobject python-werkzeug python-yaml pytz

# Install Odoo
rpm -i http://nightly.openerp.com/8.0/nightly/rpm/odoo_8.0-20140918-103809.noarch.rp

0
Jaime Vasquez
On 9/26/14, 12:49 AM

HI Andrew, I managed to install Odoo 8 in a Centos 7 (python 2.7 by default) following this instructions:

http://odootricks.wordpress.com/2014/09/18/installing-odoo-8-on-centos-7-with-virtual-python-install/

Also you will need to install Wkhtmltopdf binary for reports to work:

wget http://downloads.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-centos6-amd64.rpm

rpm -ivh wkhtmltox-0.12.1_linux-centos6-amd64.rpm

:)

 

 

0
Andrew Trueman
On 9/25/14, 10:38 AM

Hi Ben,

Thanks for taking the time to reply.

I use the command scl enable python27 bash first. If I try python -V I get

Python 2.7.5

Stil the server seems to have problems with locating files.

EDIT:

I managed to get a working script by following the instructions from the site recommended by Jaime, thank you. With a bit of editing it all worked.

However, since then David Dean (who wrote the Centos 7 instructions) has created a set of step by step instructions for Centos 6 which are very comprehensive yet easy to follow. Apart from a little (no doubt self induced) hiccup, the install method works perfectly and I can highly recommend ot. David has posted the link below.

Thank you to everyone for your replies and especially to David for taking the time and effort to put the instructions together.

0
David Dean
On 9/30/14, 6:12 PM

Installing Odoo on CentOS 6.5 is very tricky as you need a parallel Python install and a method of containing all the modules.

I've created a step-by-step installation guide you might find useful:

http://odootricks.wordpress.com/2014/09/30/installing-odoo-8-on-centos-6-with-virtual-python-install/

I used your install guide but i have an error :

UnicodeDecodeError: 'utf8' codec can't decode byte 0xe0 in position 1517: invalid continuation byte

when i try to create my first database. I use a vanilla/fresh install of odoo and pull git repo today the 11/16. I can't create database but i can change master pwd.

I use odoo v8 / python 2.7.9 / pg 8.4.20. thanks

Bonnet Denis
on 11/16/16, 6:40 AM
0

Ben Bernard

--Ben Bernard--
1083
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 9/25/14, 10:12 AM

It seems that you use the wrong python. I assume that python2.7 is available. Try trigger openerp using python2.7

> python2.7 openerp-server

The point is you have to make sure what python version to run openerp, it has to be the 2.7 version.

Maybe the init script also use the wrong python.
 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 9/25/14, 8:11 AM
Seen: 6603 times
Last updated: 9/24/16, 10:51 PM