Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Odoo v7.0 ubuntu server 14.04.2 LTS - multiple installation

By
Mike
on 7/30/15, 8:42 AM 559 views

Hi,

i have Ubuntu server 14.04.2 LTS my goal is run 2 Odoo aplications at same time.

first application run fine

user openerp 
home patch /opt/openerp
conf file /etc/openerp-server.conf

openerp-server.conf
admin_passwd = xxx
db_host = False
db_port = False
db_user = openerp
db_password = yyy
addon_patch = /opt/openerp/server/openerp/addons
logfile = /var/log/openerpe1/openerp-server.log
log_level = debug

boot file /etc/init.d/openerp-server.

#!/bin/sh
### BEGIN INIT INFO
# Provides: openerp-server
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Should-Start: $network
# Should-Stop: $network
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Enterprise Resource Management software
# Description: Open ERP is a complete ERP and CRM software.
### END INIT INFO

PATH=/bin:/sbin:/usr/bin
DAEMON=/opt/openerp/server/openerp-server
NAME=openerp-server
DESC=openerp-server

# Specify the user name (Default: openerp).
USER=openerp
# Specify an alternate config file (Default: /etc/openerp-server.conf).
CONFIGFILE="/etc/openerp-server.conf"


for my second application

user openerp2 
home patch /opt/openerp2
conf file /etc/openerp2-server.conf

openerp2-server.conf
admin_passwd = xxx
db_host = False
db_port = False
db_user = openerp2
db_password = yyy
addon_patch = /opt/openerp2/server/openerp/addons
logfile = /var/log/openerpe2/openerp-server.log
log_level = debug

boot file /etc/init.d/openerp-server.

#!/bin/sh

### BEGIN INIT INFO
# Provides: openerp-server
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Should-Start: $network
# Should-Stop: $network
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Enterprise Resource Management software
# Description: Open ERP is a complete ERP and CRM software.
### END INIT INFO

PATH=/bin:/sbin:/usr/bin
DAEMON=/opt/openerp2/server/openerp-server
NAME=openerp-server
DESC=openerp-server

# Specify the user name (Default: openerp).
USER=openerp2
# Specify an alternate config file (Default: /etc/openerp-server.conf).
CONFIGFILE="/etc/openerp2-server.conf"

i changed port 8069 to 8070 in file server/openerp/tools/config.py

group.add_option("--xmlrpc-port", dest="xmlrpc_port", my_default=8070,help="specify the TCP port for the XML-RPC protocol", type="int") 

When i type :

sudo /etc/init.d/openerp-server start 
sudo /etc/init.d/openerp2-server start
 ps aux
python /opt/openerp/server/openerp-server -c /etc/openerp-server.conf

only one application run.

Please any ideas how to start second application ?




1

Axel Mendoza

--Axel Mendoza--
10238
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 7/30/15, 9:09 AM

You do not need to change anything for that in server/openerp/tools/config.py

Just include the option xmlrpc_port in every config file that you are using specifying different ports. The other thing is you need to specify different NAME's in your init.d scripts, I mean "NAME=openerp-server". That could lead to errors when restarting or stoping your Odoo servers due to the pid file use that NAME variable and also "# Provides: openerp-server" could raise warning for update-rc.d

0
Mike
On 7/30/15, 9:53 AM

well i add lines to

/etc/openerp-server.conf
xmlrpc_por = 8069

/etc/openerp2-server.conf
xmlrpc_por = 8070
/etc/init.d/openerp-server
NAME=openerp-server


/etc/init.d/openerp2-server
NAME=openerp2-start

log openerp-server.log application 1 has started 0.0.0.0:8070

log openerp2-server.log application 2 has started 0.0.0.80:70


I belive that im very close to success, firewall ufw has 8069 and 8070 allowed.







the option is xmlrpc_port. Was is the problem now?

Axel Mendoza
on 7/30/15, 2:59 PM

both application starting at same port. htop result : openerp1 python /opt/openerp/server/openerp-server -c /etc/openerp-server.conf openerp2 python /opt/openerp2/server/openerp-server -c /etc/openerp2-server.conf all seems to be fine, unique user for each instance and /opt/openerp folder. i really dont know what i missing ..

Mike
on 7/31/15, 1:31 AM

is working now or still doesn't?

Axel Mendoza
on 9/7/15, 3:04 PM
0

Bole

--Bole--
2385
| 5 4 6
Zagreb | Karlovac, Croatia
--Bole--

there is only 10 kind of people the ones that understand binary ... and others

Bole
On 8/4/15, 7:00 AM

do not use 8069 and 8070.. try bigger range.. like : server1 : 8069, server2 : 7069 when the server is started on 8069, it is also listening on 8070 port... so use bigger range.. those two ports are too close...

btw... here is a list of all options for config file:

http://www.vionblog.com/openerp-server-conf-for-openerp-7-explained/

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 7/30/15, 8:42 AM
Seen: 559 times
Last updated: 8/4/15, 7:01 AM