Odoo Help


Odoo Sale Report PDF Custom Language

Vincent Monbaron
on 1/8/15, 11:00 AM 3,012 views

Hi everybody,

I want to change some translation (English to French) on my Odoo 8 server for the sale module.

I have for example the Quantity in English but not the disc.% The price is right in french.

How I can edit that ?


Thanks in advance


Hi Vincent! Have a look at another post where I explained quite a lot about translations. See https://www.odoo.com/forum/help-1/question/how-to-translate-terms-67357

on 1/8/15, 11:04 AM

Hello, Thank you but I can't find the "Application Terms" where is that ?

Vincent Monbaron
on 1/8/15, 11:06 AM

Its under settings. If you don't have it you still need to activate the technical features. Go to settings > users, open up the administrator account (or yours) and check on technical features.

on 1/8/15, 12:14 PM

Ah nice tricks :-) thank you ! I see now the application terms :-) Ok but now how I can see or search the "Quantity" field on the pdf sale.report_saleorder ? for change the name from Quantity to quantité ?

Vincent Monbaron
on 1/9/15, 2:17 AM

Simply do a search for "Quantity" under your translations and find the correct record. You'll then see there is a translation for it (probably also "Quantity" at the moment). Just modify that to Quantité, save it and then synchronize your translations!

on 1/9/15, 2:21 AM

I find Quantity but not the right I think, I check all the values but nothing change the quantity or a other on the rapport sale.report_sale order. Any idea why ?

Vincent Monbaron
on 1/9/15, 3:23 AM

@Vincent hmm yes it is quite tricky. You're probably translating the wrong values and/or have the wrong record ID for the translation. The thing is you need to match it exactly. Your best bet is to search a translation that is on your report, then duplicate this one and modify it too the original source+translation you'd like. Another alternative is to find the QWeb's record ID and then write a new translation. Let me know if you get this fixed or not.. If it doesn't I'll write out a full answer which describes how to do it.

on 1/9/15, 3:28 AM

I think I need you for a full answer :-) sorry

Vincent Monbaron
on 1/9/15, 4:46 AM



I’m back at office right now, I go check that J






Meilleures salutations

Mit freundlichen Grüssen


<img width="160" height="37" id="Image_x0020_1" src="cid:image001.jpg@01D02C1B.9B353900" alt="iteliumC76a-A03aT03a-Z_big">


Vincent Monbaron

[ CEO System Engineer ]


itelium Sàrl

Gurzelenstrasse 31

2502 Biel/Bienne


Tel:                         +41 32 510 05 50

Fax:                        +41 32 341 13 43

Mobile:                   +41 78 638 74 32

Email:                     vincent.monbaron@itelium.ch

Homepage:            http://www.itelium.ch


De : Yenthe spam [mailto:yenthespam@gmail.com]
Envoyé : vendredi 9 janvier 2015 14:27
À : Vincent Monbaron
Objet : Re: Odoo Sale Report PDF Custom Language



I've posted a full answer about this :)


2015-01-09 10:53 GMT+01:00 Vincent Monbaron <vincent.monbaron@mail.odoo.com>:

Off course ! thank you for the help ! :-)

Vincent Monbaron
Sent by Odoo Inc. using Odoo about Forum Post Odoo Sale Report PDF Custom Language


Sent by Odoo S.A. using Odoo about Forum Post Odoo Sale Report PDF Custom Language

Vincent Monbaron
on 1/9/15, 8:50 AM

Off course ! thank you for the help ! :-)

Vincent Monbaron
on 1/9/15, 8:57 AM

No problem Vincent! Let me know if it works out. If it does or if this answer has helped you a lot consider upvoting / accepting the answer please!

on 1/9/15, 8:59 AM

Hello, So that's work !! :-) many many thanks for your help !!!!!!

Vincent Monbaron
on 1/9/15, 10:04 AM

Awesome, that is great to hear! No problem Vincent and best of luck.

on 1/9/15, 10:11 AM

Thanks :-)

Vincent Monbaron
on 1/9/15, 10:13 AM


| 8 8 8

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

On 1/9/15, 6:38 AM

Hi Vincent

To be absolutely sure you are doing the translations on the correct lines you should first find out the correct record id.
To do this first go to Settings > Reports > Reports.

Next search for the report where you want to make / modify translations for. For example invoice:

Open up this record and you'll see an option 'Search associated QWeb views'. Click on it:

You will now see two lines, no matter which report you open. The first record fetches the user his language and is irrelevant. Open up the second one:

You will now see at the right top a field you can click on which is named "Model Data". Click on it.
A new window pops up and this is finally showing you the record id.. Phew.

This number (510) is the ID where the translations are attached to. Now that you know this go to settings > Application Terms > Translated terms. Now open up the advanced search function (small arrow down) and search on your record id (510 in my case):

You will now see a filtered list of translations which only is used by your current report. This means if there is already a record in English for the field you are searching to translate (Quantity) you can modify the translation value. If there is no record for your item yet just make a new one. You're best of to copy an existing one and modify this as the resource ID is already filled in then. Simply give in the English term and the wanted translation. For example:

Finally click on Settings > Application Terms > Synchronize Terms and synchronize your language. The report will now show the new translations!
NOTE: If you do this for an invoice you will only see the modifications when you make a new invoice after synchronizing since an invoice is never allowed to change due to legal actions.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 1/8/15, 11:00 AM
Seen: 3012 times
Last updated: 3/16/15, 8:10 AM