Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Odoo Multiple Instances Through Single IP?

By
Mazhar Iqbal Rana
on 11/17/14, 2:51 AM 2,236 views

Good Day...I have checked various resources througout the internet where you can deploy Odoo ona single machine with multiple instances with ofcourse different ports..

But is it possible to deploy odoo online using one public ip but with multiple instances?

 

Like forexample I will have abc.odoo.com/ist and abc.odoo.com/2nd... Is it possible? Instances may be multiple for one public IP?

 

I tried somehting like apache2 or wsgi but couldnt succeed..

Please Guide

 

Thanks

 

OS I am using is UBUNTU and instances are supposed to be created from Ubuntu too ofcourse

 

1

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 11/17/14, 10:39 AM

I think this should be more easy with NGINX  (of course each instance must be installed on a different folder,  running on a  different port number, and with a different addons_path ... etc ...).

Be careful: The names of the OpenERP configuration files must be different and also the names of the startup scripts if they are in the same folder (e.g /etc/openerp and /init.d ....).

Last, in the the nginx.conf file you should repeat the server section as many times as the number of instances (changing in each one the instance_port number in the proxy_pass directive (proxy_pass http://127.0.0.1:instance_port_number ).

Let me know if it works.

 

This is exactly what you need: http://mishekha.blogspot.com/2012/07/running-multiple-openerp-server-on.html

http://mishekha.blogspot.in/2011/11/connect-openerp-using-reverseproxy.html

Seems Much complex :) Lemme Try I will get back to you

Mazhar Iqbal Rana
on 11/17/14, 11:34 PM

Hey I am doing it with Nginx.. The script I sued ie below Hey.. This Ip 94.200.39.198 is my public IP I am giving in server name in nginx and complete script is below But Why not its running? In log it says * 21:29:26 [warn] 4195#0: server name "http://94.200.39.198" has suspicious symbols in /etc/nginx/sites-enabled/openerp:18 Script is: sudo nano /etc/nginx/sites-available/openerp with the following content: IMPORTANT: You will need to change all references to openerpserver.example.com in the following file to either the domain name or static IP address of your server. upstream webserver { server 127.0.0.1:8069 weight=1 fail_timeout=300s; } server { listen 80; server_name _; # Strict Transport Security add_header Strict-Transport-Security max-age=2592000; rewrite ^/.*$ https://$host$request_uri? permanent; } server { # server port and name listen 443 default; server_name 94.200.39.198; # Specifies the maximum accepted body size of a client request, # as indicated by the request header Content-Length. client_max_body_size 200m; # ssl log files access_log /var/log/nginx/access.log; error_log /var/log/nginx/error.log; # ssl certificate files ssl on; ssl_certificate /etc/ssl/nginx/server.crt; ssl_certificate_key /etc/ssl/nginx/server.key; # add ssl specific settings keepalive_timeout 60; # limit ciphers ssl_ciphers HIGH:!ADH:!MD5; ssl_protocols SSLv3 TLSv1; ssl_prefer_server_ciphers on; # increase proxy buffer to handle some OpenERP web requests proxy_buffers 16 64k; proxy_buffer_size 128k; location / { proxy_pass http://webserver; # force timeouts if the backend dies proxy_next_upstream error timeout invalid_header http_500 http_502 http_503; # set headers proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forward-For $proxy_add_x_forwarded_for; # Let the OpenERP web service know that we're using HTTPS, otherwise # it will generate URL using http:// and not https:// proxy_set_header X-Forwarded-Proto https; # by default, do not forward anything proxy_redirect off; } # cache some static data in memory for 60mins. # under heavy load this should relieve stress on the OpenERP web interface a bit. location ~* /web/static/ { proxy_cache_valid 200 60m; proxy_buffering on; expires 864000; proxy_pass http://webserver; } } and the link I used to configure through Nginx is: http://www.schenkels.nl/2013/01/reverse-ssl-proxy-using-nginx-with-openerp-v7/ Plz Guide Thanks

Mazhar Iqbal Rana
on 11/19/14, 12:46 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 11/17/14, 2:51 AM
Seen: 2236 times
Last updated: 3/16/15, 8:10 AM