Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

odoo Installation

By
Avini Wanigasinghe
on 10/14/15, 2:43 AM 658 views

I installed odoo server and the postgresql database separately. But I cann't use default postgresql port. So I used port 5433. Then I installed odoo server.  Then this issue arise. It says 'The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application'. How I resolve this problem


 

1

Axel Mendoza

--Axel Mendoza--
10203
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 10/14/15, 2:24 PM

You need to check that your PostgreSQL server it's listenning at the right network interface or '*', and using the port 5433. this could be check at the postgresql.conf file of your installation. Also you need to authorize the access to the PostgreSQL server from the Odoo server ip address, you could do that at the pg_hba.conf file of your installation. Next restart the PostgreSQL server and check if Odoo can connect to it

Thank you Axel Mendoza. But I don't understand how to authorize the access to the PostgreSQL server form the odoo server ip address. Here the pg_hba config entries in my postgreSQL installation. # TYPE DATABASE USER ADDRESS METHOD @remove-line-for-nolocal@# "local" is for Unix domain socket connections only @remove-line-for-nolocal@local all all @authmethodlocal@ # IPv4 local connections: host all all 127.0.0.1/32 @authmethodhost@ # IPv6 local connections: host all all ::1/128 @authmethodhost@ # Allow replication connections from localhost, by a user with the # replication privilege. @remove-line-for-nolocal@#local replication @default_username@ @authmethodlocal@ #host replication @default_username@ 127.0.0.1/32 @authmethodhost@ #host replication @default_username@ ::1/128 @authmethodhost@

Avini Wanigasinghe
on 10/15/15, 12:14 AM

Add a line like this:

# IPv4 local connections:
host    all             all             127.0.0.1/32            md5
host    all             all             odoo_ip_address/32         md5
Axel Mendoza
on 10/15/15, 12:20 AM

I am using localhost for load odoo for browser. Is it correct if I add odoo_ip_address as 0.0.0.0 ?

Avini Wanigasinghe
on 10/15/15, 12:33 AM

I am using localhost for load odoo for browser. Is it correct if I add odoo_ip_address as 0.0.0.0 ?

Avini Wanigasinghe
on 10/15/15, 12:33 AM

No, it's not correct. In that line you need to authorize the access from a subnet range of ip addresses, so if you specify a direct ip address you use /32, for a big range you need to do it like:
#take this subnet ip address: 192.168.1.143
192.168.1.143/32
192.168.1.0/24
192.168.0.0/16
192.0.0.0/8
0.0.0.0/0
#not sure about this

Axel Mendoza
on 10/15/15, 12:40 AM

I mean that I'm not sure about 0.0.0.0/0
Did you solve it your problem?

Axel Mendoza
on 10/15/15, 10:49 AM

Yes I solved the problem. The problem was in the openerp-config file. In there data dir should be like this--> data_dir = C:\Users\admin\AppData\Local\OpenERP S.A.\Odoo. But previously it was like this--?data_dir = C:\Users\admin_2\AppData\Local\OpenERP S.A.\Odoo. Thank you Axel Mendoza.

Avini Wanigasinghe
on 10/16/15, 2:12 AM

If your problem was solved you need to vote for the answer so it may help to others

Axel Mendoza
on 11/29/15, 2:56 AM
0
Rizan Zaky
On 10/14/15, 10:20 AM

This error most probably occurs because of a db connection error. In what environment are you working? Linux or Windows?

On windows.

Avini Wanigasinghe
on 10/14/15, 1:13 PM

edit the C:\Program Files (x86)\Odoo 8.0-20151015\PostgreSQL\data\postgresql.conf file (NOTE: take a backup of the file), change, port = 5433, then in C:\Program Files (x86)\Odoo 8.0-20151015\PostgreSQL\data\pg_hba.conf (NOTE: take a backup of the file) leave only these two lines uncommented, "host all all 127.0.0.1/32 md5", "host all all ::1/128 md5". Comment the rest of the codes. Restart PostgreSQL_For_Odoo service from Task Manager->Services. Then check whether odoo works. Good luck!

Rizan Zaky
on 10/15/15, 2:01 AM
0
Andrei Boyanov
On 10/14/15, 5:40 AM

Did you change the database port configuration in openerp-server.conf?


db_port = 5433


Also, it's a good idea to see the Odoo logs as this error doesn't sound to me as a database connection problem...

Yes I have changed.

Avini Wanigasinghe
on 10/14/15, 1:14 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 10/14/15, 2:43 AM
Seen: 658 times
Last updated: 10/15/15, 12:20 AM