Odoo Help

0

Odoo doesn't send email

By
Chris
on 7/11/18, 7:17 AM 473 views

Everything is in the title. 

When i try to send a quotation to a client, the email doesn't go out.

When I try to setup smtp email , I get an error when I test the connection. And yes, all the information are proper both for mail server adress, username, password and port.

Pleae help.

PS: I am on vps at digital ocean.

first allow less secure apps from your google account and then test the email configuration

For incoming mail server:

smtp server:smtp.gmail.com

port:465

connection security:ssl/tls

ABHISHEK E
on 7/12/18, 6:32 AM
2
Muhammed Nishad
On 7/13/18, 6:19 AM

Dear chris,

            please mention your connection detailes for more info. And try to paste the error here or upload a screenshot.

            if you are using smtp server with gmail,

            the below detailes can be of help

            port:465
            smtp server : smtp.gmail.com
            connection security: SSL/TLS

               and make sure you have entered the correct login and password.

              Also try setting up the mail after loging in to the browser.

               and for gmail , you have to enable less secure apps in order to use odoo.

            To enable less secure apps

                    you can use this link:

                        https://myaccount.google.com/lesssecureapps?pli=1

0
Jeremy
On 7/12/18, 3:28 AM

DigitalOcean is known to block email ports such as 25, 587, 465 etc by default on most droplets. Please first make sure that you can connect to your SMTP service by doing:

telnet smtp.gmail.com 25

What do you get in response?

Further, I would recommend you use a transactional SMTP / Mail service to send emails out from Odoo, instead of gmail. Mandrill has a free plan that you can use.

0

Ermin Trevisan

--Ermin Trevisan--
8286
| 6 5 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 7/11/18, 5:59 PM

Obviously you are not able to setup your SMTP account properly. However, you should not use the Gmail default SMTP server anyway, but the G-Suite relay SMTP server instead for obvious reasons. Please read Odony's answer here:

https://github.com/odoo/odoo/issues/21119

and Google's instructions here:

https://support.google.com/a/answer/2956491?hl=en

and follow the deployment instructions of Odoo here:

https://www.odoo.com/documentation/user/11.0/discuss/email_servers.html


0
Chris
On 7/11/18, 9:21 AM

@rishan I tried already. Didn't work better.

Connection Test Failed! Here is what we got instead:
534
5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=somecoderhere> Please log in via your web browser and
5.7.14 then try again.
5.7.14 Learn more at

5.7.14 https://support.google.com/mail/answer/78754 q8-v6sm3808909wmb.3 - gsmtphen I try to connect with the Test connect with Gmail here is what I get: .


Here is current configuration I have on odoo 

localhost1
Connection Information
smtp.gmail.com465


Security and Authentication
SSL/TLS
my_user_name@gmail.com
passwordhere


my alias domain in the general settings is setup with my own domain name


I am on Odoo 10 CE. 

I don't even see where is the parameter for changing cron task frequency.

Google Account is set as accepting unsecure apps


When you tried with Gmail have you added Odoo API to trusted on google? I have noticed recently that whenever Odoo tried to send an email I got a notification from Gmail that "Not secure app tried to log to your email"

Piotr Cierkosz
on 7/11/18, 9:33 AM

no, where to do this ?

Chris
on 7/11/18, 9:40 AM

How to do this ?

Chris
on 7/11/18, 9:42 AM

I have tried the telnet command requested by @Jeremy and here is the result:

Trying 66.102.1.109...

Connected to gmail-smtp-msa.l.google.com.

Escape character is '^]'.

220 smtp.gmail.com ESMTP o8-v6sm37143825wro.68 - gsmtp

Chris
on 7/13/18, 9:01 AM
0
Kevin Peterson
On 7/11/18, 9:52 AM

Sign into google.

Goto google apps. (top right)

Select Account.

sign in and security->apps with account access.

Scroll down and turn on

Allow less secure apps...

That should do the thing......

0
Rishan Malaka
On 7/11/18, 8:55 AM

first try with the gmail account using google smtp configuration. 

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 7/11/18, 7:17 AM
Seen: 473 times
Last updated: 7/13/18, 6:19 AM