Help

7

Odoo CSS and JS not loading when hosted by wsgi or run by gunicorn

Avatar
swapnil wagh

Recently I encouter an new error I can't say whether its an eror or any congifuration issue but when I updated by odoo 8 server to new stable build css and js of odoo are not loading specially when odoo is deploy using wsgi previously with my old odoo installation it was working properly.

Same issue when I run odoo 8 with gunicorn

gunicorn openerp:service.wsgi_server.application -c openerp-wsgi.py

You can see the error in below screen shot

https://drive.google.com/file/d/0B4fbJ-xTa7pDckZEUlBzX2NobWc/view?usp=sharing

https://drive.google.com/open?id=0B4fbJ-xTa7pDbmF3UUctVnFGQ2M&authuser=0

10 Comments
Avatar
Discard

Do you have a delay on your webshop when you click on pay now or when downloading PDF's too? If so you will need to set your web.base.url and web.base.url.freeze. I will provide an answer if your answer is yes on my questions.

Avatar
swapnil wagh
-

@Yenthe, I think your question is not related to my issue, but still I never have delay in webshop paymnet process, I used paypal I have not tested it with any other payment method, when you click on pay now its ajax call so you might feel delay but its not the case, can you still provide answer to my question

Well just give this a try, it only takes like two minutes and you've got nothing to lose I guess. :) Go to settings > Parameters > System parameters and edit your web.base.url to have the value http://0.0.0.0:8069/ (or your IP address) Now create a new parameter with the name web.base.url.freeze and as value True. Save these two and refresh your page. I'm curious if this fixes your problem..

Avatar
swapnil wagh
-

@Yenthe, Thanks for your comment, but it did not fixes my problem, what you told was already there my web.base.url value contains my ip address, still I change it to 0.0.0.0:8069 just to give a try , but still issue persist. Do you have any other approach.

Does your logfile provide anymore details / problems? Perhaps there is some more information there.

Avatar
swapnil wagh
-

No handlers could be found for logger "openerp.modules.module" This is the error in log file

Looks like a problem in a module. Did you recently install a new module? I think one of the modules didn't install correctly. If you do have new installed modules update/re-install them. If this doesn't fix it start your Odoo manually in your terminal with ./openerp-server and have a look what it prints out there. Those reports are way more detailed.

Avatar
swapnil wagh
-

I don't think its a problem of module its a fresh installation without any new module, and when I run openerp using script or ./openerp-server command everything works fine.

If you run the script or ./openerp-server you say everything works fine.. are your errors also gone then? Or are they still there? If the errors are still there, even when manually starting, I'm afraid somebody else will need to help you as I'm out of ideas then!

Avatar
Kinner Vachhani
-

I am having similar issue, looks like this is still ongoing and not fixed yet.

1 Answer
6
Avatar
swapnil wagh
Best Answer

When I did same deployment on ubuntu 12.04 and apache 2.2 it works for me, like to know is there any issue with wsgi module came with apache 2.4 in ubuntu or is there any issue with odoo I dont think there is any problem with odoo.

Avatar
Discard