Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Odoo 8 installs but "500 Internal Server Error". encoding Problem? Win 10-User with umlauts.

By
Julian Scherrer
on 7/30/16, 11:17 AM 381 views

Hello, I love to be here. I installed a similar version of Odoo 8.0.20160729 (which i try to run now on my machine) on another machine. It worked without problems and i really love it.

Specs. recent machine:

Odoo 8.0.20160729 with "PostgreSQL 9.3.5, compiled by Visual C++ build 1600, 32-bit"

pgAdmin 1.18.1

Firefox 47.0

User "Hörner-PC/Hörner" in Win 10 home on a x64 machine

Problem:

I cant login into Odoo: "500 Internal Server Error". I reinstalled Odoo in different folders (last: "C:\Odoo8"). Before the reinstallation i cleansed my pc of the old installation. Running openerp_server.exe in cmd showed an encoding error ([1] - UnicodeEncodeError). [2] led to a solution (unset client_encoding in postgresql.conf , restart service PostgreSQL_for_Odoo) . This led to the next Error ([3] - "no password supplied"). Solved by [4] (pg_hba.conf - for all IPv6 local connections: replaced "md5" with "trust"). Which led to ([5] - role doesn't exist, showing encryption errors). I am not sure if this is a problem with encoding or with a nonexisting user.

[1] - "UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 10: ordinal not in range(128)"

[2] - https://github.com/odoo/odoo/issues/835

[3] - OperationalError: "fe_sendauth: no password supplied"

[4] - http://stackoverflow.com/questions/33928585/python-and-postgresql-operationalerror-fe-sendauth-no-password-supplied

[5] - OperationalError: FATAL: role �H�rner� doesn't exist

Questions:

I could search on for solutions but i fear that this will lead to a series of other errors. Is there a general mistake i made, that leads to these errors?

Not beeing experienced in SQL, I didn't really understand the structure behind Odoo. What i understood: Odoo uses (in a way) PostgreSQL by using the user "openpg". This works: openpg is logged in localhost:5432 according to pgAdmin. But what does "INFO ? openerp: database user: Hörner" mean in this context?

Thanks very much

every help is appreciated!

INFO and ERROR messages are from the Odoo log and tell you a little bit about what's happening on the backend of things.

Htm-Mbs, Travis Waelbroeck
on 7/30/16, 4:18 PM
1

Ermin Trevisan

--Ermin Trevisan--
3524
| 6 3 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 7/31/16, 3:09 AM

Do you mean that "Hörner-PC/Hörner" is supposed to be your internal Odoo database user? If yes, you have to provide me a taster of your dope :-)

In a standard Odoo installation, the internal Odoo database user is "odoo". You might well change that, even if I see no reason for it, but in that case please try to avoid any non-standard ASCII characters.

1

Ahmed M.Elmubarak

--Ahmed M.Elmubarak--
2988
| 5 3 5
Sudan
--Ahmed M.Elmubarak--


Ahmed M.Elmubarak
On 7/31/16, 4:48 AM

Hi,

You can use pgadmin to create a new role with the supplied name [Hörner as in your case] by odoo log ...

Update:

or try to use the server parameters to enforce the db user:

--db_user <user here e.g openpg >, --db_password <password>

when you're running the server ...


hope this could helps

0
Julian Scherrer
On 7/31/16, 5:14 AM

Thanks to all who helped or wanted to help!


The Error on the machine wasn't solved. I now use Odoo 8 on a virtual machine, which worked from the beginning.

=========================================

Htm-Mbs, Travis Waelbroeck, Ermin Trevisan, Ahmed M.Elmubarak. Hello, grüetzi and As-salam alaykom! Thank you very much for your answers!

To make this clear: i did not use "Hörner-PC/Hörner" as username for Odoo. I do use "Hörner" to login to Windows. The name of my machine, my pc is "Hörner-PC". I never specified any username for using Odoo (i can't access it in any way, as mentioned above - 500 internal server error). The only username i was able to choose was the postgreSQL "openpg"-username during the Odoo all-in-one-installer installation. But I kept this standard username.

I didn't set any Odoo-specific username. If I understand correctly, odoo logs into postgreSQL by using usr "openpg" (see https://pl.vc/1i1zpy ). How come that i get

C:\Odoo8\server>openerp-server.exe
2016-07-31 08:19:07,546 8988 INFO ? openerp: OpenERP version 8.0-20160729
2016-07-31 08:19:07,546 8988 INFO ? openerp: addons paths: [u'C:\\Users\\H\xf6rner\\AppData\\Local\\OpenERP S.A.\\Odoo\\addons\\8.0', u'C:\\Odoo8\\server\\openerp\\addons']
2016-07-31 08:19:07,562 8988 INFO ? openerp: database hostname: localhost
2016-07-31 08:19:07,562 8988 INFO ? openerp: database port: 5432
2016-07-31 08:19:07,562 8988 INFO ? openerp: database user: Hörner
2016-07-31 08:19:08,891 8988 INFO ? openerp.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069

The database user differs from the one shown by pgAdmin. AND it is my windows username.

I tried to add the role "Hörner". It didn't work. I still get "OperationalError: FATAL: role �H�rner� doesn't exist".


This PC once was infedted by a virus. Is it possible that this scrambled the encoding?



Answer to Ermins comment from 31.07. 12:04:

this is the content of my openerp-server.conf:

[options]

addons_path = C:\Odoo8\server\openerp\addons

admin_passwd = admin

auto_reload = None

bin_path = C:\Odoo8\thirdparty

csv_internal_sep = ,

Adding

database user = openpg

or

user = openpg

won't change a thing


===============================

Thanks to all who helped or wanted to help!

The Error on the machine wasn't solved. I now use Odoo 8 on a virtual machine, which worked from the beginning.

================================


Hello Ermin, hello Ahmed,

thank you very much again for your answers. As soon as it's possible i'll give your ideas a try. As i'm not a my machine at the next days, it'll take a while.

Julian

Check your openerp-server.conf file, there you will find the database user and in your case it should be "openpg" and not "Hörner".

Ermin Trevisan
on 7/31/16, 6:05 AM

It must be:

db_user = openpg

db_password = False

Ermin Trevisan
on 7/31/16, 10:19 AM

updated my answer ...

Ahmed M.Elmubarak
on 8/1/16, 1:50 AM

updated my answer

Julian Scherrer
on 8/1/16, 11:50 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/30/16, 11:17 AM
Seen: 381 times
Last updated: 7/31/16, 5:14 AM