Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

ODOO 8 Installed but not working

By
Jayant Bulbule
on 10/5/14, 5:21 AM 1,594 views

I am very new to ODOO, both 7 & 8. I had installed 7 about a week or so back and then noticed a release of version 8. The version 7 got completely installed and was also working on my Windows 7 Laptop. However, when I downloaded and installed version 8, nothing is working since. Neighter 7 nor 8.

I tried removing both versions completely from my machine, including the PostGreSQL and registry stamps too, as indicated on this forum. Then, installed both versions one-by-one. None of them worked and keep giving me error message as -

(1) "Uh-oh, something went wrong! Error Code: 500" OR

(2) "Internal Error"

Could someone guide me what did I do wrong? How to correct it? I am desperate to install and ODOO 8 (preferably) and evaluate it to know if it suits my requirement. I need to run it for my company that is an Online Retail store dealing in Fresh Produce and Grocery.

Thanks in advance for all the help.

Rgds

When/where are you getting those error messages? Is it on installation or when it tries to start up? Is there anything in the log file?

Robert D Winchester
on 10/5/14, 2:04 PM

The error is showing up at start-up of OpenERP. To best of my understanding and as per log file, there is an error in database connection. Log says "File "psycopg2\__init__.pyc", line 164, in connect OperationalError: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432? received invalid response to SSL negotiation: -" In the "Services" the database service "PostgreSQL_For_OpenERP" is in "Stop" state. When trying to "Start" the service, the error is flashed as "Operation could not be completed. The service did not start due to Logon failure". Logon to service through service --> Properties shows "This Accoount = .\openpgsvc". The logon does not work anyway. During installation, there was an error that flashed during the installation, related to Database connection setup. What could be tried?

Jayant Bulbule
on 10/6/14, 1:41 AM
Hi Robert,

Thanks for your help. Below is the summary of what happened and happens.

The error is showing up at start-up of OpenERP. To best of my understanding and as per log file, there is an error in database connection. Log says "File "psycopg2\__init__.pyc", line 164, in connect OperationalError: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432? received invalid response to SSL negotiation: -"

In the "Services" the database service "PostgreSQL_For_OpenERP" is in "Stop" state. When trying to "Start" the service, the error is flashed as "Operation could not be completed. The service did not start due to Logon failure".

Logon to service through service --> Properties shows "This Accoount = .\openpgsvc". The logon does not work anyway.

During installation, there was an error that flashed during the installation, related to Database connection setup.

What could be tried?

Thanks again for all your help.

Regards,
Jayant Bulbule


On Sun, Oct 5, 2014 at 11:34 PM, Robert D Winchester <tech4@mail.odoo.com> wrote:

When/where are you getting those error messages? Is it on installation or when it tries to start up? Is there anything in the log file?

--
Robert D Winchester
Sent by OpenERP S.A. using Odoo about Forum Post ODOO 8 Installed but not working

Jayant Bulbule
on 10/6/14, 1:42 AM

Yeah, that is what I thought would be the case; you are not connecting to Postgres. Seems your Postgres isn't even starting and that is the source of your problems. I would suggest that you open up a terminal window and use the Postgres command line to try to connect to a database, any one. See which users work for which DBs. Try to login as the Postgres root user and access the DB named "postgres", that is where all the base info for the DBs is kept. Then list all DBs then list all users for each DB. Figure out which users can access what and that may show you the problem right there. You can get support on the Postgres command line on their website. What might have happened when you installed 8 with 7 is that the Postgres user and/or the database structure may have been changed. You also may have both versions using the same DB and it may be incompatible with both. But start with figuring out if the right user can even access the DB. Is your user named "odoo"?

Robert D Winchester
on 10/6/14, 1:44 PM

Or, as an alternative, uninstall both versions and Postgres again but also delete the Odoo and Postgres user accounts and everything owned by them, including the Postgres data. Then install ONLY v8 and see what happens. That may fix things and be quicker.

Robert D Winchester
on 10/6/14, 1:47 PM

Hi Robert,

Thanks a ton for your help. I too guessed so and actually have uninstalled both versions and postgres (in fact just formatted the HDD). Now will download ODOO and start afresh.

Wondering if 8 would be better (from stability perspective) or go with time tested V7. Actually lot tempted with features of v8, particularly the eCommerce module and website builder.

On Oct 6, 2014 11:17 PM, "Robert D Winchester" <tech4@mail.odoo.com> wrote:

Or, as an alternative, uninstall both versions and Postgres again but also delete the Odoo and Postgres user accounts and everything owned by them, including the Postgres data. Then install ONLY v8 and see what happens. That may fix things and be quicker.

--
Robert D Winchester
Sent by OpenERP S.A. using Odoo about Forum Post ODOO 8 Installed but not working
Jayant Bulbule
on 10/6/14, 1:56 PM
0
Robert D Winchester
On 10/6/14, 3:51 PM

I'd go with 8.  There are a ton of new features but also the inherent fixes that come with every version update.  There are lots of examples of things that have been imporved and fixed, like the new API.  Even if they have a few bugs now those will be worked out soon and when they are you will have a more stable package as well as one  with better features.

Let me know if the reinstall fixes it, please.  I am curious.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/5/14, 5:21 AM
Seen: 1594 times
Last updated: 3/16/15, 8:10 AM