Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo 8 Debug Error

Zakir Husain
on 10/1/14, 1:12 PM 6,233 views


     I have Install odoo 8 on my linux System. when i am debuging it it run an stuck on one point. can someone help me out that what could be the problem.

2014-10-01 17:08:37,001 2263 INFO ? openerp: OpenERP version 9.0alpha1
2014-10-01 17:08:37,002 2263 INFO ? openerp: addons paths: ['/home/yusuf/.local/share/Odoo/addons/9.0', u'/home/yusuf/odoo/openerp/addons', u'/home/yusuf/odoo/addons']
2014-10-01 17:08:37,002 2263 INFO ? openerp: database hostname: localhost
2014-10-01 17:08:37,003 2263 INFO ? openerp: database port: 5432
2014-10-01 17:08:37,004 2263 INFO ? openerp: database user: yusuf
2014-10-01 17:08:39,046 2263 INFO ? openerp.service.server: Evented Service (longpolling) running on
2014-10-01 17:09:13,712 2263 INFO ? openerp.http: HTTP Configuring static files
2014-10-01 17:09:14,782 2263 INFO HRMS openerp.modules.loading: loading 1 modules...
2014-10-01 17:09:19,339 2263 INFO HRMS openerp.modules.loading: 1 modules loaded in 4.30s, 0 queries
2014-10-01 17:09:19,950 2263 INFO HRMS openerp.modules.loading: loading 29 modules...
2014-10-01 17:09:29,792 2263 INFO HRMS openerp.modules.loading: 29 modules loaded in 9.84s, 0 queries
2014-10-01 17:09:32,231 2263 INFO HRMS openerp.modules.loading: Modules loaded.
2014-10-01 17:09:32,500 2263 INFO HRMS openerp.addons.base.ir.ir_http: Generating routing map - - [2014-10-01 17:09:52] "GET /web HTTP/1.1" 200 25796 54.206552
2014-10-01 17:09:52,810 2263 INFO HRMS openerp.addons.bus.bus: Bus.loop listen imbus on db postgres



Thanks & Regards,

Yusuf Ali

Dorin Hongu
On 11/7/14, 12:00 AM

In /opernerp/__init__.py are these lines at start.

if sys.modules.get("gevent") is not None:
    evented = True

Comment these lines and will work

Thanks Dorin, with this change it worked even on PyCharm Community Edition 4.06

Jose Osuna
on 5/8/15, 11:36 AM

That was the solution for me. But what is the impact?

OdooTec, Hesham ELMAHDY
on 5/19/15, 2:54 PM

Thanks man!

on 9/10/15, 2:52 PM

Thanks. Works fine on my pycharm ide. After updating pycharm, i could not debug python.

on 12/30/15, 3:01 AM
Hendrik ten Hoor
On 10/15/14, 6:02 PM

You do not give any details about the IDE you are using. I had the same problem using Eclipse verrsion 4.2.2 and PyDev version 3.8.0. It would start the Odoo server properly using the command "Run - Configuration". However the server did not start properly using the command "Run - Debug Configuration". Switching back to PyDev version 3.5.1 solved the problem.

Version 3.5.1 is wat you get when you use http://pydev.org/nightly as the update site instead of http://pydev.org/updates

Hope this solves your problem.



Thanks, mate. I sent a bug-report to pydev

on 10/28/14, 6:34 AM

Thanks, pydev 3.5 worked ok for me on ubuntu 14.04 using eclipse 3.7.2

Cinxgler Mariaca
on 10/28/14, 10:14 AM

I was using pydev , Dorin Hongu solution worked for me.

on 9/10/15, 2:52 PM
On 1/8/16, 9:00 PM

You only remove gevent module.

apt-get remove python-gevent

This apt-get remove python-gevent fixed my problem on debug =) thx

on 4/26/16, 8:00 AM
Mario Arias Badila
On 12/25/14, 9:56 PM

I guess your problem is that you have gevent installed and you are starting odoo using openerp-server script...

Odoo will detect this and try running gevent version (that enables the chat extension on Odoo). If you start Odoo using openerp-gevent then you don't need apply changes to base code...


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)


Asked: 10/1/14, 1:12 PM
Seen: 6233 times
Last updated: 8/8/16, 10:09 PM