Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo 8 and odoo 9 instances on same server. Issue?

on 3/21/16, 2:24 PM 331 views

I have odoo 8 installed on our server. I need odoo9 as well on same server with different database on same postgres server. So I installed odoo9. I am running it at different xmlrpc port no. I am getting the option to create database in odoo9. But it display the blank page with no 'Apps' & 'Settings' option. Please help?

To run odoo9, I am using cmd:

python odoo.py --xmlrpc-port 9069 --db_port 5432 -w odoo9 -r odoo9 --db_host localhost -d odoo9 --addons-path=addons,odoo_magento_connector --db-filter=odoo9

Basically using the same server is not recommended for both Odoo 8 and Odoo 9. Although you have two separate databases it would clash and might create in loading Odoo. Hence, as per my understanding having separate servers would be an remedy to your issue.

on 3/22/16, 2:33 AM

Thanks Nilim, but I have installed odoo8 and odoo9 in my local with same database server. Its working fine in my local system.

on 3/22/16, 2:38 AM

@Nilim: there are absolutey no reasons not to have multiple Odoo instances on one server. You simply create multipe Odoo instances next to eachother, which all use the same PostgreSQL. There is no reason not to do that..

on 3/22/16, 2:54 AM
Holden Rehg
On 3/22/16, 11:39 AM

I would recommend reading this article on setting up multiple Odoo instances on the same server https://medium.com/@reedrehg/managing-multiple-odoo-instances-1e4c8bdabb4#.3sd73dm61.

The three main pieces that will be different are the code, the postgres users / databases, and the port.

You will want to make sure to use separate Postgres users for each instance, so they both own their own databases without being able to affect the other users / systems databases.

As you said, you will also want to run it on a different xmlrpc_port.

On 3/22/16, 11:14 AM

remember to change the

data_dir = 

parameter in the config file, it has to be different for each installation

On 3/22/16, 10:52 AM

Try to run it without the  --db-filter=odoo9 option

Thanks All. This issue was happening due to the non compatibility of my customer modules with odoo9. It was not showing error on console but when i tried with only default addons it was working fine. I need to make changes in my customer modules according to odoo9.

on 3/22/16, 1:08 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 3/21/16, 2:24 PM
Seen: 331 times
Last updated: 3/22/16, 11:39 AM