Help

2

Odoo 12 Connection Lost... Trying to reconnect on nginx

Avatar
Paulo Matos

Hello everyone,

I am having a very strange problem with Odoo 12 CE running on a Ubuntu 18 server.

When I try to access Customers or Suppliers (from any place... accounting, sales, purchases...) I have a "Connection lost... trying to reconnect" error.

The server was running fine and need to make some updates and noticed this error occurred.

After trying to figure out what was the problem, have decided to proceed like:

- Upgraded Core Odoo 12 installation files;

- Tried on a fresh database with basic modules installed (invoicing, sales, purchase and inventory). Same error happens

- On odoo-server.conf file I added:

limit_time_cpu = 3600
limit_time_real = 3600

- Based on some forums information's, I edited my nginx file with:

proxy_connect_timeout 3600;
proxy_send_timeout 3600;
proxy_read_timeout 3600;
send_timeout 3600;

I am still unable to solve the issue.

I can use all Odoo applications and any menu item. The problem just happens when I try to access "Customers or Supplier" menu options from anywhere, even on a new database.

Looking for the logs, I don't see any error that might be related to this. Only normal errors like missing translation terms, same description for different fields on models, etc and everything from Odoo core addons.

Have anyone faced a problem like this?

Can anyone help me try to solve it?

Thank you all in advance

Best regards

PM



2 Comments
Avatar
Discard
Avatar
Paulo Matos
-

Dear @Jignesh,

I have tried the solutions above and did not help.

I also can confirm that the problem is not related to Nginx because the same happens even with Nginx server disabled.

I am sure it's something related with SO (Ubuntu 18.04 server) and/or some Odoo / Python dependency.

I am still working on it and will keep post updated.

Thank you once again

Best regards

PM

Avatar
SYSMART
-

Hi,

Facing same pb but when trying to access invoice views. Did you find any solution?

3 Answers
0
Best Answer

Hello, 

I ran into this Error in a V13 CE database I was testing on. 

Solved it by adding a couple of workers in the Odoo config file. Haven't exactly found the cause of the problem, but this seems to have removed the issue.

Hope this helps

Avatar
Discard
0
Avatar
Helpdesk #1
Best Answer



I'm having the same issue here with the Quality module.  I have tried all suggestions above as well.

This is what I see each time the error occurs in the Odoo log:

Sep 18 21:58:47 odoo Odoo Server 12.0:odoo:DEBUG:odoo.api:call quality.tag(17, 25, 18, 20, 22, 23, 16, 15).read(['display_name']) 
Sep 18 21:58:47 odoo Odoo Server 12.0:odoo:INFO:werkzeug:192.168.51.34 - - [18/Sep/2019 21:58:47] "POST /web/dataset/call_kw/quality.tag/read HTTP/1.1" 200 - 
Sep 18 21:58:48 odoo Odoo Server 12.0:odoo:INFO:werkzeug:192.168.51.34 - - [18/Sep/2019 21:58:48] "POST /web/dataset/search_read HTTP/1.1" 200 - 
Sep 18 21:58:52 odoo Odoo Server 12.0:odoo:DEBUG:odoo.modules.registry:Multiprocess signaling check: [Registry - 314 -> 314] [Cache - 10761 -> 10761] 
Sep 18 21:58:52 odoo Odoo Server 12.0:odoo:INFO:werkzeug:192.168.51.34 - - [18/Sep/2019 21:58:52] "POST /web/webclient/version_info HTTP/1.1" 200 -


Avatar
Discard
0
Avatar
Jignesh Jarsaniya
Best Answer

Please try by removing the limit time from the conf file as well timeout from the Nginx file. If it's work that you need to configure the time limit accordingly. 

1 Comment
Avatar
Discard
Avatar
Paulo Matos
-

Dear @Jignesh,

I have tried the solutions above and did not help.

I also can confirm that the problem is not related to Nginx because the same happens even with Nginx server disabled.

I am sure it's something related with SO (Ubuntu 18.04 server) and/or some Odoo / Python dependency.

I am still working on it and will keep post updated.

Thank you once again

Best regards

PM