Odoo Help

0
0
saritha sahadevan
On 2/17/18, 1:47 AM

Hi Hannes Horting,

We cant use public IP address to sync odoo with google calender. If you are using localhost.then use  http://localhost:8069/google_account/authentication while creating credentials.If it is public IP, you should use a domain.

0

Hello,

I have the same problem with the synchronisation of google calendar even I'm using our public IP for creating the API credentials. The router is forwarding the port 8069. Everything is working fine and It is possible to connect from outside to our local odoo server.

The first try was with the following URI: http://121.xxx.xxx.xxx:8069/google_account/authentication

For the second try I configured DNS of a domain name I had left to our server. After 24 hours the DNS was working and I used the following URI for the API credentials: http://ourdomain.ch:8069/google_account/authentication

After pressing the synchro button I get allways the same error:

400. That’s an error.
Error: invalid_request
device_id and device_name are required for private IP: http://10.0.0.5:8069/google_account/authentication

Why is still used my local IP? What is wrong and where should I change this settings?

Greets Stefan

PS: Im using odoo 11 CE

0
jpryor@acumen.com.co
On 7/22/18, 1:00 PM

Try the following:

1. Configure your router to forward requests on port 8069 to 192.168.0.206

2. Find out your public address

3. Configure your api with http://your.public.add.ress:8069/google_account/authentication

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 3/8/17, 5:04 AM
Seen: 1207 times
Last updated: 9/2/18, 5:41 AM