Help

0

OAuth "You do not have access to this database or your invitation has expired."

Avatar
Jordan Miles

I'm trying to set up OAuth on my localhost Odoo instance. I have an Okta OAuth client that I'm using that I set up through "OAuth Providers" in settings. I can get to Okta to login and redirect back to Odoo, but I get OAuth error 3 and "You do not have access to this database or your invitation has expired." As a control, I also attempted to use the Odoo OAuth out of the box and I have the same error. I'm running OAuth 11. Please help! I'm at a complete loss.

1 Comment
Avatar
Discard
Avatar
Hilar AK
-

possibly you are using old link or some thing like that for login. also try after adding the db_filter on your config file / maintain only single db.

2 Answers
0
Avatar
Yogesh
Best Answer

In my case I was trying to signup new users (without invitataion) on V12 I had to activate option 
"Free sign up" 



Avatar
Discard
0
Avatar
Gino Gervasio
Best Answer

I ran into this problem recently when I tried to connect our account to use Google OAuth.  If you have existing users and you want to change the OAuth handler, you need to change it under `Settings > Users > OAuth > OAuth provider` and then click `Re-send Invitation Email`.  After you click the link in the email, login with the new OAuth handler instead of using your old credentials.  If you do this correctly, you should see it populate the OAuth User ID and OAuth Access Token under `Settings > User > OAuth`. Hope this helps.

Avatar
Discard