Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Not printing the bar code picking v8

By
Melvin Martinez
on 8/1/14, 8:31 AM 5,617 views

When sending to print the barcode picking is not printing, I need to install any dependencies. I'm testing the v8 version in ubuntu 12.04 lts

anyone can help me?

Melvin Martinez
on 8/1/14, 10:22 AM

Dear Melvin, I have the same problem only I am on Ubuntu 14.04. I do get a product label which works when I go to the scanning part in picking and just scan that label. But I would like to be able to scan a picking order line, so the line is processed at once.

Mibo, Michael Bos
on 9/20/14, 5:49 AM

I have the same question. I have installed code 128 font and nothing happens. When I print the picking there are a blank square in the position of barcode

Josep Xifra
on 10/21/14, 12:24 PM

** I still haven't 20 karma points, so my solution is to go here, sorry ** Fixed on my installation in Ubuntu 14.04. 1.- Download this ZIP ( http://www.reportlab.com/ftp/pfbfer.zip ) and extract 2.- Create folder named "fonts" in " /usr/lib/python2.7/dist-packages/reportlab/". If the folder exists, go to step 3. 3.- Copy content of folder extracted in "fonts" folder 4.- Restart server Remember to make all of this with root permissions

Josep Xifra
on 10/22/14, 5:48 AM

Dear Josep, This makes my server crash! It works untill I add the font's folder to the reportlab folder. My server is then unable to print any picking and it becomes unresponsive. Restarting Odoo through init.d or service option (ubuntu) both won't work.

Mibo, Michael Bos
on 11/22/14, 2:55 AM
5
Rakesh Sindhav (RSI)
On 11/26/14, 8:09 AM

Hi,
1.- Download ZIP and extract http://www.reportlab.com/ftp/pfbfer.zip
2.- Create folder named "fonts" in " /usr/lib/python2.7/dist-packages/reportlab/"
3.- Copy content of folder extracted in "fonts" folder
4.- Restart server

Rakesh, I have the same problem. It crashes the server with the same fault as 92Trades has. Is there a proper fix available? I haven't found it yet!

Mibo, Michael Bos
on 12/20/14, 3:18 AM

Have you attempted all the steps with the root permission on Ubuntu system ? And can you give me the configuration that you are using ? Try to start your server with [-d database name -u base] module. Hope it will solve your problem. Thanx.

Rakesh Sindhav (RSI)
on 12/22/14, 12:23 AM

I did Rakesh. I will try starting the server as you said. It works till the part where I try to print the report. It then makes me restart the whole system before I can acces Odoo again. A simple "service odoo restart" doesn't work, also stopping odoo and all afflicted processes and then restarting them also doesn't work. I updated to the newest nightly build and now it doesn't crash anymore. But it also doesn't show any barcode!

Mibo, Michael Bos
on 12/22/14, 1:46 AM

Are you sure that you put all the fonts in the "/usr/lib/python2.7/dist-packages/reportlab/fonts/" directory with the Root permission from the extracted file http://www.reportlab.com/ftp/pfbfer.zip (Or download it again, may be file is crashed, Restart the System) ?

Rakesh Sindhav (RSI)
on 12/22/14, 2:27 AM

Rakesh, I want to thank you and confirm that this solution works for me. I use Ubuntu 14.04 with Odoo 8.0.

Budi Hartono
on 8/26/15, 5:17 AM
0
Dawari George
On 12/9/14, 5:32 AM

hello, your solution above does not work, infact it crases the system and keeps loading forever, is there a proper solution to fix the barcode issue on picking list please?

0
Robin Vincent
On 2/26/16, 7:10 AM

Any help is much appreciated:

two days ago i followed this post and everything worked. I was able to print barcodes from the location page along with product codes.

Last night i was adding more locations and found out that it is no longer printing barcodes fomr the location page or the pick list page. However it does print barcodes form the product.

I have checked, permissions (everything is root) i have tried to redo the directions here with not effect the fonts folder is there and populated with files.

I have restarted odoo and the server and still just a box where the barcode should be.

The server does not hang and in fact works great other no bar codes.

I have tailed the logs for odoo, apache and syslog with not meaningful results.

Does anyone have any idea where i should look next?

0
Fernando
On 10/30/15, 2:52 PM

I want to say the above answer is fine. I solved the problem in that way and I have windows 7. thanks a lot.

Note: Remember to restart the server.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 8/1/14, 8:31 AM
Seen: 5617 times
Last updated: 2/26/16, 7:10 AM