Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


node: No such file or directory

on 10/2/15, 3:14 PM 438 views

Anybody else having this problem in Ubuntu 14.04?

I have tried

sudo ln -s /usr/bin/nodejs /usr/bin/node
sudo apt-get install nodejs-legacy
sudo update-alternatives --install /usr/bin/node node /usr/bin/nodejs 10 

Nothing seems to work. Thank you.


Ermin Trevisan

--Ermin Trevisan--
| 6 3 7
Walchwil, Switzerland
--Ermin Trevisan--

Ermin Trevisan
On 10/3/15, 6:34 AM

Did you try this method: https://www.odoo.com/fr_FR/forum/help-1/question/9-0-cluttered-user-web-interface-problems-with-nodejs-npm-and-less-91647? If you still prefer nodejs-legacy, then you should note, that this already contains the proper symlink, see http://stackoverflow.com/questions/21168141/can-not-install-packages-using-node-package-manager-in-ubuntu for further information.

Have done but still had the problem. I tried using enterprise version and it worked. so i believe dependencies and nodejs were correctly installed. Just a few hours ago, i tried to clone community verision again from github and it worked but the interface looked differently (the top bar is same as black top bar in v8 and blue sidebar is still there).

on 10/3/15, 7:03 AM

The community edition has a different UI than the edition. Check https://www.odoo.com/fr_FR/editions

Ermin Trevisan
on 10/3/15, 9:32 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 10/2/15, 3:14 PM
Seen: 438 times
Last updated: 10/3/15, 6:34 AM