Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

No success with installing saas-5 on Ubuntu 12.04

By
birduser
on 6/20/14, 6:16 PM 1,698 views

Hello,

I am under ubuntu 12.04 and tried as written on github adding the source:

deb http://nightly.openerp.com/8.0/deb/ ./

but its not existing...

Then I tried:

wget -O- https://raw.githubusercontent.com/odoo/odoo/master/odoo.py | python

which is not working too. Then I tried:

bzr branch lp:~openerp/openerp-web/saas-4 web

bzr branch lp:~openerp/openobject-server/saas-4 server

bzr branch lp:~openerp/openobject-addons/saas-4 addons

but whicht is saas-4:

bzr branch lp:~openerp/openerp-web/saas-5 web

(...)

is not working...

Then I tried installing the deb manually:

wget http://nightly.openerp.com/trunk/nightly/deb/openerp_8.0dev-20130206-011033-1_all.deb

sudo dpkg -i openerp_8.0dev-20130206-011033-1_all.deb

which is not working....

C'mon guys, am I stupid or is this a Joke?

However, I figured it out, but it's not THAT easy you told us at the Open Days and like this its actually not usable.

I made it this way:

Installing dependencies

sudo apt-get install graphviz ghostscript postgresql-client \

python-dateutil python-feedparser python-matplotlib \

python-ldap python-libxslt1 python-lxml python-mako \

python-openid python-psycopg2 python-pybabel python-pychart \

python-pydot python-pyparsing python-reportlab python-simplejson \

python-tz python-vatnumber python-vobject python-webdav \

python-werkzeug python-xlwt python-yaml python-imaging

 

sudo apt-get install gcc python-dev mc bzr python-setuptools python-babel \

python-feedparser python-reportlab-accel python-zsi python-openssl \

python-egenix-mxdatetime python-jinja2 python-unittest2 python-mock \

python-docutils lptools make python-psutil python-paramiko poppler-utils \

python-pdftools antiword postgresql

 

Add postgres user

sudo -u postgres createuser -s odoo

 

Add Ubuntu user

sudo adduser odoo --home /opt/odoo

 

cd /opt/odoo

Download ZIP from github

sudo wget https://github.com/odoo/odoo/archive/master.zip

sudo unzip *

cd odoo-master

Change User

su odoo

Start Server

./openerp-server

 

BUT when I click on "Module" -> "Apps" I come back to "installed modules" and when I click on "Update modules" nothing happens while my modules folder is filled with modules... Why? Am I wrong, or is there a mistake?

0
David Arnold
On 6/20/14, 7:41 PM

Servus, probier mal: https://github.com/odoo-colombia/odoo-vagrant

Funzt garantiert.

Oder auch: https://github.com/odoo-colombia/provisioning/tree/master/varios/vagrant-ubuntu-shell (musst aber die odoo_install.sh anpassen OE_VERSION="saas-4" -> OE_VERSION="saas-5"

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/20/14, 6:16 PM
Seen: 1698 times
Last updated: 3/16/15, 8:10 AM