Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

"No matching record found for name 'xxxxx' in field 'xxxxx' at row x"?

By
Joel Prendes
on 10/19/13, 7:25 PM 4,591 views

I am trying to import a CSV of leads into the Sales/Leads section. My CSV file does not have an ID field so I would expect OpenERP to create that value in import. My only required field in the crm.lead model (Lead/Opportunity) is the name field (Field Label = Subject). I have added this field to me CSV and mapped it accordingly on the import screen. All fields are mapped, all fields in the CSV are within defined parameters for that field in OpenERP, and other than the missing ID field, this CSV is formatted identically to the res.partner.csv that OpenERP recommends exporting from the demo data (comma-delimited, double-quote-qualified - a typical CSV). Here's the first line:

"Abbey College, London","Abbey College, London Lead","22 Grosvenor Gardens Belgravia Belgravia London SW1W 0DH","020 7824 7300","020 7824 7309","emailhere","/sitelinkhere/","Abbey College, London, Belgravia is an independent school for boys and girls aged from 15 to 22. Takes boarders.","Westminster",130,"Non-denominational","Our aim is to guide our students to achieve academic success and fulfil their aspirations so as to enable them to access top universities. We respect and value each student, providing a friendly, safe and supportive environment where each person can learn and grow in confidence. We help you to develop key skills to succeed: resiliance, adaptability, independence and determination.;If you wish to...","£17,500 - £27,000 pa"

I've tried everything on this file and when I try to validate and/or import the file after mapping I get the same error(s):

No matching record found for name 'Abbey College, London' in field 'Company' at row 1 Get all possible values No matching record found for name 'Abercorn School' in field 'Company' at row 2 Get all possible values No matching record found for name 'Aberdour School' in field 'Company' at row 3 Get all possible values

...all the way down to line 120, the end of the file. And of course it does not import. I'm probably just being thick, don't hesitate to tell me if I am, but can someone please tell me what I am doing wrong?

I am running OpenERP 7.x on Ubuntu 13.04. Not sure what else you need in terms of system spec, but tell me and I'll be happy to fill in more details.

0
Joel Prendes
On 10/21/13, 7:54 PM

Thanks - this was helpful - I think I was missing the requirement for an ID field as it doesn't come up in the list of fields under the Lead/Opportunity model as a 'required' field. I edited the first lines to read, in part:

"id","partner_name","name","x_Lead_FullAddress... "Schools01_01","Abbey College, London","Abbey College, London Lead","22 Grosvenor Gardens...

Then tried re-importing - all the fields mapped properly this time. I've still got a bit of work to do with it to change the form views now, but thanks for the help.

0
Nhomar Hernandez
On 10/19/13, 7:56 PM

Hello.

The "Company" is a many2one field, the import feature use "search" method with "Ilike" criteria to select the foreing id and set it in the many2one field.

THen. When you pass the company with "'Abbey College, London" you are passisng the "get_name" result not the "Unique sercheable name".

You have 3 options:

Pass Abbey College only, "If you have only 1 company that match with this criteria.".

Change the header of the field in your csv: company_id/.id (see the (.)) and change Abbey College by the sql id of your company (frequently 1 if you have a mono company enviroment).

Ignore this field "company_id" -Only in monocompany enviroments.

thanks a bunch...

Joel Prendes
on 10/21/13, 7:55 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/19/13, 7:25 PM
Seen: 4591 times
Last updated: 8/12/16, 4:54 PM