Odoo Help


"No handler found" - CRITICAL ? openerp.modules.module - How to downgrade/uninstall a module in command line?

on 8/9/13, 7:50 AM 3,130 views

While upgrading "France comptabilite" I got errors about rights at first then about a "already existing" report.
Due to murphy's law, I had to reboot the server.

I get a "No Handler found" on the firefox web page.

In the openerp-server.log, I get the same error:
AssertionError: The report "report.l10n.fr.bilan" already exists!

I checked and tried:

  1. ' "No handler found." error. How to fix it? ' - /300/no-handler-found-error-how-to-fix-it/
  2. ' no-web-module-found-wrong-path ' - /13857/no-web-module-found-wrong-path/
  3. 'no-handler-found-message-on-established-install' - /7177/no-handler-found-message-on-established-install/
  4. 'i-got-module-installation-problem-i-cant-install-any-module-help-me-please' - 23356/i-got-module-installation-problem-i-cant-install-any-module-help-me-please/

What would be the way to uninstall/downgrade the module or modify things in the /addons folder ?

Full log:

2013-08-09 08:40:14,157 1463 INFO ? openerp: OpenERP version 7.0-20130725-231029
2013-08-09 08:40:14,158 1463 INFO ? openerp: addons paths: /usr/lib/pymodules/python2.6/openerp/addons,/usr/lib/pymodules/python2.6/openerp/addons/web/addons
2013-08-09 08:40:14,158 1463 INFO ? openerp: database hostname: myhostname
2013-08-09 08:40:14,159 1463 INFO ? openerp: database port: myport
2013-08-09 08:40:14,159 1463 INFO ? openerp: database user: openerp
2013-08-09 08:40:15,678 1463 INFO ? openerp.addons.google_docs.google_docs: GData lib version %s GData-Python/2.0.2 detected
2013-08-09 08:40:15,992 1463 CRITICAL ? openerp.modules.module: Couldn't load module web
2013-08-09 08:40:15,993 1463 CRITICAL ? openerp.modules.module: The report "report.l10n.fr.bilan" already exists!
2013-08-09 08:40:15,993 1463 ERROR ? openerp.service: Failed to load server-wide module web.
The web module is provided by the addons found in the openerp-web project.
Maybe you forgot to add those addons in your addons_path configuration.
Traceback (most recent call last):
File "/usr/lib/pymodules/python2.6/openerp/service/__init__.py", line 60, in load_server_wide_modules
File "/usr/lib/pymodules/python2.6/openerp/modules/module.py", line 415, in load_openerp_module
getattr(sys.modules['openerp.addons.' + module_name], info['post_load'])()
File "/usr/lib/pymodules/python2.6/openerp/addons/web/http.py", line 628, in wsgi_postload
File "/usr/lib/pymodules/python2.6/openerp/addons/web/http.py", line 517, in __init__self.load_addons()
File "/usr/lib/pymodules/python2.6/openerp/addons/web/http.py", line 580, in load_addons
m = __import__('openerp.addons.' + module)
File "/usr/lib/pymodules/python2.6/openerp/modules/module.py", line 133, in load_module
mod = imp.load_module('openerp.addons.' + module_part, f, path, descr)
File "/usr/lib/pymodules/python2.6/openerp/addons/l10n_fr~1/__init__.py", line 30, in <module> import report
File "/usr/lib/pymodules/python2.6/openerp/addons/l10n_fr~1/report/__init__.py", line 30, in <module> import bilan_report
File "/usr/lib/pymodules/python2.6/openerp/addons/l10n_fr~1/report/__init__.py", line 30, in <module> import bilan_report
File "/usr/lib/pymodules/python2.6/openerp/addons/l10n_fr~1/report/bilan_report.py", line 36, in <module> report_sxw.report_sxw('report.l10n.fr.bilan', 'account.move.line','addons/l10n_fr/report/bilan_report.rml', parser=bilan, header=False)
File "/usr/lib/pymodules/python2.6/openerp/report/report_sxw.py", line 392, in __init__ report_rml.__init__(self, name, table, rml, '')
File "/usr/lib/pymodules/python2.6/openerp/report/interface.py", line 65, in __init__ super(report_rml, self).__init__(name)
File "/usr/lib/pymodules/python2.6/openerp/report/interface.py", line 45, in __init__ assert not self.exists(name), 'The report "%s" already exists!' % name
AssertionError: The report "report.l10n.fr.bilan" already exists!
2013-08-09 08:40:16,014 1463 INFO ? openerp.service.wsgi_server: HTTP service (werkzeug) running on
2013-08-09 08:40:16,020 1463 INFO ? openerp: OpenERP server is running, waiting for connections...


Grover Menacho

--Grover Menacho--
WebVision Enterprise Systems
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Odoo Developer

Grover Menacho
On 8/9/13, 11:39 AM

Look into the code of the module and find "report.l10n.fr.bilan", change it's name just for a while. Then you can enter to the system. It's making a conflict with other report so look for it, maybe you have the module twice on your addons folder.

Good idea! That would have been a great solution! In the meantime, I tried other things (ending to lose a VM backup... Murphy's law...) that makes me redo all the work from the beginning.

on 8/9/13, 3:00 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)


Asked: 8/9/13, 7:50 AM
Seen: 3130 times
Last updated: 3/16/15, 8:10 AM