Welcome!

This community is for professionals and enthusiasts of our products and services.

Register
0

"No handler found" after fresh install

By
Michael Wassmer
on 6/24/13, 6:51 PM3055 views

I installed OpenERP 7 on a Centos 6.3 box.

When I open the browser and go to the OpenERP address, i get the error : "No handler found"

I activated debug mode, and here's what I get :

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp:addons paths: /usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/addons

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp:database hostname: localhost

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp:database port: 5432

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp:database user: openerp

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp.addons.google_docs.google_docs:GData lib version %s GData-Python/2.0.17 detected

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:CRITICAL:openerp.modules.module:Couldn't load module web

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:CRITICAL:openerp.modules.module:[Errno 1] Opération non permise: '/tmp/oe-sessions-openerp' Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:ERROR:openerp.service:Failed to load server-wide module web.#012The web module is provided by the addons found in the openerp-web project.#012Maybe you forgot to add those addons in your addons_path configuration.#012Traceback (most recent call last):#012 File "/usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/service/__init__.py", line 60, in load_server_wide_modules#012 openerp.modules.module.load_openerp_module(m)#012 File "/usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/modules/module.py", line 415, in load_openerp_module#012 getattr(sys.modules['openerp.addons.' + module_name], info['post_load'])()#012 File "/usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/addons/web/http.py", line 628, in wsgi_postload#012 openerp.wsgi.register_wsgi_handler(Root())#012 File "/usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/addons/web/http.py", line 520, in __init__#012 path = session_path()#012 File "/usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/addons/web/http.py", line 505, in session_path#012 os.chmod(path, 0700)#012OSError: [Errno 1] Opération non permise: '/tmp/oe-sessions-openerp'

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp:OpenERP server is running, waiting for connections...

Jun 24 21:57:22 ns2299407 OpenERP Server 7.0-20130623-231037:?:INFO:openerp.service.wsgi_server:HTTP service (werkzeug) running on 0.0.0.0:8069

Specifically there seems to be a problem with the "web" module, as it says "Couldn't load module web"

I double checked my addons path and it is set correcly in openerp-web.cfg like this :

addons_path = /usr/lib/python2.6/site-packages/openerp-7.0_20130623_231037-py2.6.egg/openerp/addons

also the "web" module folder is there in the /addons folder. I don't know why it cannot load it.

What am I doing wrong ?

edit : I finally solved the problem. The issue was that during the install, when creating the postgresql user, I was giving him a password instread of just pressing enter twice and giving him super admin rights. I am using the Centos install script provided by "nachum234" (search on Google as I don't have enough karma to post links yet)


1
Ray Carnes
On 6/25/13, 12:14 AM

web has it's own addons folder beneath it.

You need to have that web/addons in your path also.

Currently your server is looking in addons but needs to be looking in addons AND web/addons


By default there is no /web folder in my /openerp. Do I need to create an empty /web/addons folder then ?

Michael Wassmer
on 6/25/13, 3:09 AM

No. Re-read my answer. I suggested that the /web folder in your /addons folder is actually a container for a set of addons, so you just need to add /openerp/addons/web/addons to your addons_path.

Ursa Information Systems, Ray Carnes
on 6/25/13, 4:56 PM

I am getting the same problem. It seemed to me also that the system was looking for that openerp/addons/web/addons folder but that folder does not exist! When I saw the above post I tried adding it but it just generates some errors.

Robert D Winchester
on 6/27/13, 8:04 PM

Interesting observation: When I shut down OERP 7 server and then attempt to go to 0.0.0.0:8069 it still gives the same error, not "This webpage is not available". Seems like an instance of OERP may already be running. I check the system processes: nothing. Did "ps -A | grep opene" and still got nothing. But I have OERP 6.1 on the same box, using another port. It was working but now is doing the same thing as 7.0. Possible interference between them?

Robert D Winchester
on 6/27/13, 8:19 PM

Rebooted the server, checked to see if either 6.1 or 7.0 web pages would work and both said "This webpage is not available". Good. Started OERP 7.0 server as usual and now it is working. So, for some reason, there were hidden instances running before and clogging up the ports. Providing this info for your trouble-shooting info only.

Robert D Winchester
on 6/27/13, 8:39 PM

More info: On another reboot it wouldn't work again. Checked the log and found a reference to a "extra" module that I had downloaded from the Net and put in the addons folder hoping to install and test: openerp_prestashop_sync (version specifically indicated for OERP v7). Removed it from the addons folder and restarted openerp-server and now it works again. Are we not allowed to install any modules that aren't in the "standard" list or we get this error? Or is the module defective? Any info would help the hundreds who seem to be wrestling with this issue in this and many other posts.

Robert D Winchester
on 6/28/13, 1:36 AM

I found the issue in my case, see edit on the question.

Michael Wassmer
on 6/28/13, 8:13 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/24/13, 6:51 PM
Seen: 3055 times
Last updated: 3/16/15, 8:10 AM