Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

No handler Error?? Why?

By
Mazhar Iqbal Rana
on 9/7/14, 12:33 PM 777 views

These are lastbf ew lines of my log file..

 

2014-09-06 20:21:24,829 2368 INFO ? werkzeug: 127.0.0.1 - - [06/Sep/2014 20:21:24] "GET /favicon.ico HTTP/1.1" 404 -
2014-09-07 16:12:41,293 3488 INFO ? openerp: OpenERP version 7.0-20140622-231040
2014-09-07 16:12:41,336 3488 INFO ? openerp: addons paths: C:\Program Files (x86)\OpenERP\Server\server\openerp\addons
2014-09-07 16:12:41,336 3488 INFO ? openerp: database hostname: localhost
2014-09-07 16:12:41,336 3488 INFO ? openerp: database port: 5432
2014-09-07 16:12:41,336 3488 INFO ? openerp: database user: admin
2014-09-07 16:12:41,443 3488 CRITICAL ? openerp.modules.module: Couldn't load module web
2014-09-07 16:12:41,443 3488 CRITICAL ? openerp.modules.module: No module named http
2014-09-07 16:12:41,444 3488 ERROR ? openerp.service: Failed to load server-wide module `web`.
The `web` module is provided by the addons found in the `openerp-web` project.
Maybe you forgot to add those addons in your addons_path configuration.
Traceback (most recent call last):
  File "C:\Program Files (x86)\OpenERP\Server\server\.\openerp\service\__init__.py", line 60, in load_server_wide_modules
  File "C:\Program Files (x86)\OpenERP\Server\server\.\openerp\modules\module.py", line 405, in load_openerp_module
  File "C:\Program Files (x86)\OpenERP\Server\server\.\openerp\modules\module.py", line 133, in load_module
  File "C:\Program Files (x86)\OpenERP\Server\server\openerp\addons\web\__init__.py", line 4, in <module>
ImportError: No module named http
2014-09-07 16:12:41,663 3488 INFO ? openerp: OpenERP server is running, waiting for connections...
2014-09-07 16:12:41,815 3488 INFO ? openerp.service.wsgi_server: HTTP service (werkzeug) running on 0.0.0.0:8069
2014-09-07 16:13:39,710 3488 INFO ? werkzeug: 127.0.0.1 - - [07/Sep/2014 16:13:39] "GET /?ts=1409765540920 HTTP/1.1" 404 -
2014-09-07 16:13:39,842 3488 INFO ? werkzeug: 127.0.0.1 - - [07/Sep/2014 16:13:39] "GET /favicon.ico HTTP/1.1" 404 -
2014-09-07 16:14:16,727 3488 INFO ? werkzeug: 127.0.0.1 - - [07/Sep/2014 16:14:16] "GET / HTTP/1.1" 404 -

 

 

Trhough Browser I receive No Handler Found Error and this has happened when I added new addons taken from Github

 

Please Guide

 

Thanks

 

1

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 9/7/14, 1:01 PM

It seems you don't have web addons in your odoo server directory.

0
Mazhar Iqbal Rana
On 9/7/14, 2:40 PM

I have now done a fresh install again

 

Just tell me one thing please

IS IT NECESSARY TO HAVE ADDITIONAL ADD-ONS by Github? Why we put them in? Are they necessary?  Thanks Tc

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/7/14, 12:33 PM
Seen: 777 times
Last updated: 3/16/15, 8:10 AM