Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

No backend after install module

By
Henk
on 4/30/15, 4:19 AM 599 views

Hi,

After installing some modules i have no backend, the website is ok.

The menu is available but can't select / click on links.

I have tried on console if the server is running and this is what come out:

odoo@droplet1:~$ /opt/odoo/odoo/openerp-server

2015-04-30 07:53:55,578 2955 INFO ? openerp: OpenERP version 8.0

2015-04-30 07:53:55,578 2955 INFO ? openerp: addons paths: ['/opt/odoo/.local/share/Odoo/addons/8.0', u'/opt/odoo/odoo/openerp/addons', u'/opt/odoo/odoo/addons']

2015-04-30 07:53:55,578 2955 INFO ? openerp: database hostname: localhost

2015-04-30 07:53:55,579 2955 INFO ? openerp: database port: 5432

2015-04-30 07:53:55,579 2955 INFO ? openerp: database user: odoo

2015-04-30 07:53:55,709 2955 INFO ? openerp.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069

Exception in thread openerp.service.httpd:

Traceback (most recent call last):

File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner

self.run()

File "/usr/lib/python2.7/threading.py", line 763, in run

self.__target(*self.__args, **self.__kwargs)

File "/opt/odoo/odoo/openerp/service/server.py", line 281, in http_thread

self.httpd = ThreadedWSGIServerReloadable(self.interface, self.port, app)

File "/opt/odoo/odoo/openerp/service/server.py", line 91, in __init__

handler=RequestHandler)

File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 410, in __init__

HTTPServer.__init__(self, (host, int(port)), handler)

File "/usr/lib/python2.7/SocketServer.py", line 419, in __init__

self.server_bind()

File "/opt/odoo/odoo/openerp/service/server.py", line 101, in server_bind

super(ThreadedWSGIServerReloadable, self).server_bind()

File "/usr/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind

SocketServer.TCPServer.server_bind(self)

File "/usr/lib/python2.7/SocketServer.py", line 430, in server_bind

self.socket.bind(self.server_address)

File "/usr/lib/python2.7/socket.py", line 224, in meth

return getattr(self._sock,name)(*args)

error: [Errno 98] Address already in use

What can i do about it

Thx

Henk

1

zbik

--zbik--
5941
| 6 4 7
Lodz, Poland
--zbik--


zbik
On 4/30/15, 7:55 AM

Error 98 is raised when another process listening on port. Probably are several openerp process running on your system. Open your terminal and type following command:

ps aux | grep openerp

Kill all process which openerp-server

sudo kill -9 PROCESS_ID

Then restart the openerp-server.

PS. Suggestion, you enable debug and openerp-server log file. The log has more informations.

0
Henk
On 4/30/15, 9:51 AM

Hi thank for your reply, but it doesn't worked.

Now the complete site and backend is gone......

:(

edit: did a server reboot, site is showing ok but backend is still not available.

The strange thing is, the backend is available with the Android odoo app ????

Thx

Henk


This is in the log file ..:


127.0.0.1 - - [30/Apr/2015 20:14:49] "GET /web/js/web.assets_backend/78273ca HTTP/1.1" 500 -

2015-04-30 20:14:49,091 2362 ERROR vdwillikwijne werkzeug: Error on request:

Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi

execute(self.server.app)

File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute

application_iter = app(environ, start_response)

File "/opt/odoo/odoo/openerp/service/server.py", line 280, in app

return self.app(e, s)

File "/opt/odoo/odoo/openerp/service/wsgi_server.py", line 216, in application

return application_unproxied(environ, start_response)

File "/opt/odoo/odoo/openerp/service/wsgi_server.py", line 202, in application_unproxied

result = handler(environ, start_response)

File "/opt/odoo/odoo/openerp/http.py", line 1215, in __call__

return self.dispatch(environ, start_response)

File "/opt/odoo/odoo/openerp/http.py", line 1189, in __call__

return self.app(environ, start_wrapped)

File "/usr/lib/python2.7/dist-packages/werkzeug/wsgi.py", line 579, in __call__

return self.app(environ, start_response)

File "/opt/odoo/odoo/openerp/http.py", line 1356, in dispatch

result = ir_http._dispatch()

File "/opt/odoo/odoo/addons/crm/ir_http.py", line 13, in _dispatch

response = super(ir_http, self)._dispatch()

File "/opt/odoo/odoo/addons/website/models/ir_http.py", line 125, in _dispatch

return super(ir_http, self)._dispatch()

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_http.py", line 130, in _dispatch

return self._handle_exception(e)

File "/opt/odoo/odoo/addons/website/models/ir_http.py", line 201, in _handle_exception

return super(ir_http, self)._handle_exception(exception)

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_http.py", line 100, in _handle_exception

return request._handle_exception(exception)

File "/opt/odoo/odoo/openerp/http.py", line 596, in _handle_exception

return super(HttpRequest, self)._handle_exception(exception)

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_http.py", line 126, in _dispatch

result = request.dispatch()

File "/opt/odoo/odoo/openerp/http.py", line 614, in dispatch

r = self._call_function(**self.params)

File "/opt/odoo/odoo/openerp/http.py", line 283, in _call_function

return checked_call(self.db, *args, **kwargs)

File "/opt/odoo/odoo/openerp/service/model.py", line 113, in wrapper

return f(dbname, *args, **kwargs)

File "/opt/odoo/odoo/openerp/http.py", line 280, in checked_call

return self.endpoint(*a, **kw)

File "/opt/odoo/odoo/openerp/http.py", line 733, in __call__

return self.method(*args, **kw)

File "/opt/odoo/odoo/openerp/http.py", line 376, in response_wrap

response = f(*args, **kw)

File "/opt/odoo/odoo/addons/web/controllers/main.py", line 527, in js_bundle

response = request.make_response(bundle.js(), [('Content-Type', 'application/javascript')])

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_qweb.py", line 1176, in js

content = ';\n'.join(asset.minify() for asset in self.javascripts)

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_qweb.py", line 1176, in <genexpr>

content = ';\n'.join(asset.minify() for asset in self.javascripts)

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_qweb.py", line 1383, in minify

return self.with_header(rjsmin(self.content))

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_qweb.py", line 1379, in with_header

return '\n/* %s */\n%s' % (self.name, content)

UnicodeDecodeError: 'ascii' codec can't decode byte 0xef in position 0: ordinal not in range(128)


Thx

Henk


You remove session files or refresh many times (5-10) backend site. This should help if there are no errors in the log.

zbik
on 4/30/15, 1:05 PM

Does posgresql use utf8 as default encoding? Does your server locale uses utf8 encoding? Or.... encoding problem in installed module.

zbik
on 4/30/15, 5:14 PM

It happend when i installed a new module, but its not in the normal module map. I think its encoding problem. Thx Henk

Henk
on 4/30/15, 5:16 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/30/15, 4:19 AM
Seen: 599 times
Last updated: 4/30/15, 4:27 PM