Odoo Help

0

Next Sequence Number Cannot Update

By
aci aisha
on 2/19/15, 5:16 AM 1,147 views

Friends,

I created a sequence with prefix TM..

I created some files and it generates the following sequences,

   TM001

   TM002

   TM003

Then i delete them all..

So now i want to create files with seq TM001

So i go to settings>Technical>Sequences&Identifiers>Sequences

       Next Number : 1

But when i save it till remain as 4(Not Updated)

Can u help me

Thanks

0
Ludo - Neobis
On 2/19/15, 5:32 AM

You need to reset the counter in postgres for this.

ALTER SEQUENCE $yoursequence RESTART

should do the trick.

ddnt get..can u plz xplain some more

aci aisha
on 2/19/15, 5:34 AM

Is it q query?After this can i edit it through Settings?

aci aisha
on 2/19/15, 5:34 AM

It's a query. Run it on your db.

Ludo - Neobis
on 2/19/15, 5:38 AM

what i put in the place of $..I put my sequence name ..but it cause the following error,,ERROR: syntax error at or near "$"

aci aisha
on 2/19/15, 5:39 AM

Your sequence should be there, something like ir_sequence_0035 or so. You will have to figure out which one it is for yourself.

Ludo - Neobis
on 2/19/15, 5:41 AM

I tried this,ALTER SEQUENCE ir_sequence_TM:0001 RESTART ..but the same error

aci aisha
on 2/19/15, 6:16 AM

Perhaps it would be best for you to first read the postgres documentation to see what went wrong.

Ludo - Neobis
on 2/19/15, 6:24 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 2/19/15, 5:16 AM
Seen: 1147 times
Last updated: 3/16/15, 8:10 AM