Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

New User (Set as Sales Manager) not able to see list of Companies

By
Rex
on 3/13/13, 11:20 AM 1,796 views

As the Admin, I imported a list of companies and then created a new user with Sales Manager rights. All imported companies are accessible by the admin, but when I switch over to the new Sales Manager user none of the companies are visible. The Sales Manager does have the ability to create a new Customer and/or Company.

I logged back in as the admin and created a new company manually and then went back and logged in as the Sales Manager but even this manually created company was not visible.

I saw another question that was about the same as mine and the answer was to select the allowed companies in the settings/user/access rights but that is not an option on V7.

Is their a toggle someplace I am missing?

I am having exactly the same issue Rex. In addition - and it may be related, my sales manager cannot create a company/partner.

Shane
on 3/14/13, 9:02 AM
0
Rex
On 3/28/13, 5:58 PM

UPDATE: @Martin; @ Bob .I have discovered what might have been a "duh" to many, particularly our European users. There are two different "Companies" in OpenERP. The Company you can see when signed in with full admin privileges that you see under settings is the "Your Company". Since OpenERP supports multi-companies you create multiple Owned or "Your Companies". If you use settings/companies/import the system assumes these are all "Your Companies" so only users with access would see them. The companies (customer companies) I was wanting to import should be imported through Sales/Customers/Import, then you can follow the above answer and other users will be able to see. Remember that you must have the User can Import/Export box checked in General Settings and when you are at Sales/Customers you must be in list view or you can't see the import button. Also when you import the Companies you must have a column "Is a Company" and the field must be marked TRUE.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/13/13, 11:20 AM
Seen: 1796 times
Last updated: 3/16/15, 8:10 AM