Odoo Help


New states' translations not showing up

Timo Talvitie, Vizucom Oy
on 11/3/13, 2:03 PM 1,295 views

I have customized the sale module with some new fields and states. All the terms have been translated, and for the new fields they show up fine inside OpenERP, but the new states keep displaying only the original English term instead of the Finnish translation.

What I've tried so far:

  • Restarting the server and upgrading base module
  • Exporting the .po template file again and doing the whole translation from scratch
  • Installing a completely new database from scratch
  • Setting my custom module's sequence manually to 150 as per the suggestion here

...but none of the methods got the state translations showing up.

When I log in to PostgreSQL and look at the ir_translation table the translations are there and their status is set to translated, but they still don't show up inside OpenERP. What could be the issue here?

Anton Chepurov
On 12/10/13, 10:03 AM

Although not a fully automated solution, this did the job for me:

  • Restart the server
  • Settings => Translations => Import/Export => Import Translation => fill Lang. Name & Code, select your .po file and mark 'Overwrite Existing Terms'.

The fully automated update, indeed, only happens for the new terms. To manually remove the outdated terms and let the update fetch the newest translations is not an acceptable solution, I guess :)

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)


Asked: 11/3/13, 2:03 PM
Seen: 1295 times
Last updated: 3/16/15, 8:10 AM