Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

new install of odoo v8 broken

By
Laurent
on 11/16/14, 1:32 PM 1,798 views

I have installed odoo v8 with git on a debian 7 server. Everything was fine until after the creation of the database from the odoo database manager through the browser. Then, I had a login prompt asking email and password, and no menu. I couldn't login, even has admin or odoo with the admin password set in the configuration file /etc/odoo-server.conf

Then I decided to stop the odoo-server service and delete the database from postgresql. I restarted odoo-server, came back to the site where I am redirected to the odoo database manager url. But with this:

Is there some kind of flag file somewhere I should delete? What may happen here? What can I do to finalize my installation? For information, I successfully installed odoo on another server. I have tried to reproduce the same process here. Obviously, I did something wrong.

I have the same problem on a shared-hosting server and this was my first time installing Odoo. I used the tutorial here: https://doc.odoo.com/install/linux/ so it may have to do sth with the way they recommend to set up the database

IT GlowMe
on 11/16/14, 2:57 PM

The two methods presented here are the same I tried. Could you identify precisely what was wrong with your initial setup?

Laurent
on 11/17/14, 2:09 AM

Hi Laurent, I've seen this screen a number of times and it usually suggests that there is no database connection. Can you post back with more information on what method you used for installation? I've got a script that I use that (should) install on Debian 7.6 (wheezy) without any issue here: https://raw.githubusercontent.com/lukebranch/odoo-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh I'd recommend doing a fresh install of Debian 7.6 and then do the following: 1) sudo wget https://raw.githubusercontent.com/lukebranch/odoo-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh 2) sudo sh odoo_install.sh if you run into any issues please open an issue on the script's repo here: https://github.com/lukebranch/odoo-install-scripts/issues And i'd be glad to help. Alternatively i'd recommend changing: log_level = info in /etc/odoo-server.conf to log_level = debug and restarting your odoo-server. Then visit your browser as before and then check /var/log/odoo/odoo-server.log to see what the issue is.

Luke Branch
on 11/17/14, 3:06 AM

this problem is the database you work on it not compatible with this version , i have this problem when i run odoo in old database (from v7) .

sameer alhwety
on 11/19/14, 9:59 AM

Thank you very much for your help. @Luke, I am going to try it. @sameer alhwety, I am on a new install. PossiblyDebian packages are not enough uptodate? I will check that.

Laurent
on 11/20/14, 4:11 PM

A few small things that may not fix your problem but can't hurt to eliminate side effects when testing: - Use --db-filter to limit the database to just the one you are working with and trying to fix. Too often I've had Odoo looking over at another database - Launch with switches -u all and -d [yourdatabase] and force an update across the entire database. I will typically do this launch manually and watch the log go by for errors. Note I always backup a database before I do a -u all... what can fix can also do harm so error on the side of caution. - Clear all your cookies... seems silly but it can cause side effects and make it harder to troubleshoot. - Explicitly go to the /web/database/manager and shift-refresh. If you are not getting a clean database manager screen after the above steps then you probably have a problem with permissions on directories or a the addons path not getting found... possibly a bad install altogether. - Not all Odoo builds are rock solid across all applications. Particularly when working with the master branch you will want to do some up front testing before moving over any existing database. Do a clean database install (go back and set db-filter as required), gets it up and running and quickly run through all the modules and their basic processes you plan to use. This is something I typically do with any new build just to make sure I don't spend a ton of time getting a database into a Odoo build that has fundamental issues. - If your database is even slightly out of version you may have to take some rather desperate measures to recover. With the master branch in particular be prepared to dig into Postgres records to delete views manually, add/remove fields, change constraints on tables,etc. It can be done but every situation is different. Hope this helps you. Greg

First Class Computer Consulting, Greg Moss
on 11/20/14, 4:28 PM
0
Mustafa Küçük
On 5/3/15, 12:15 PM

Windows 7 için çözüm;

1. Uninstall odoo server

2. Uninstall postgresql server

3. Regedit dosyasında  odoo ve postgresql e ait kayıtları siliniz

4. Yeni bir kullanıcı açınız "administrator" yetkisine sahip

5. Restart windows 7

6. install odoo for windows

Belki sizde de işe yarar,

Mustafa Küçük (istanbul)


0
Fernando
On 11/22/14, 2:27 PM

I have the same problem. I am using the same instalation script that I used some weeks ago. And then everything worked well. The software downloaded, ubuntu, python, odoo, may have some changes. I have no solution.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

5 follower(s)

Stats

Asked: 11/16/14, 1:32 PM
Seen: 1798 times
Last updated: 5/3/15, 12:15 PM