Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Module install interrupted and now I can't login

By
Dale
on 7/14/15, 4:41 AM 1,205 views

Hi All 


I was busy installing the web report module and the server was rebooted. Now I am getting errors trying to log in to the database again. I think the incomplete module installation has caused a problem. Errors at the top of the page are in the example below:

Could not get content for /website/static/src/css/snippets.css defined in bundle 'website.assets_editor'

Could not get content for /website/static/src/css/editor.css defined in bundle 'website.assets_editor'


And so on. How can i unistall or re-install this module from the command line alone?


Thanks


1

Axel Mendoza

--Axel Mendoza--
10238
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 7/14/15, 5:08 AM

You could update the module/s that fails to install issuing and execute to the server using --update command line argument like:

/opt/odoo/odoo.py --config /path/to/config --update module


Thanks Axel I will try that. Do you think it would be better if I tried to install the module again rather? If so how do I do it from the command line?

Dale
on 7/14/15, 6:57 AM

I think you should reinstall your addons First, then add all your modifications. If its not Ok, so reinstall all your directories then add your new modules.

Drees Far
on 7/14/15, 7:33 AM

Axel I tried this but it didn't seem to do anything at all. It just goes starts the server again and when i log in I have the same problem

Dale
on 7/14/15, 7:53 AM

Thanks Drees. How do you reinstall the modules using the command line?

Dale
on 7/14/15, 10:30 AM

I see these errors now in my terminal when starting the server: odoo@ubuntu:/home/wyradmin$ /opt/odoo/odoo.py -u website_report 2015-07-14 15:04:45,481 1184 INFO ? openerp: OpenERP version 8.0 2015-07-14 15:04:45,482 1184 INFO ? openerp: addons paths: ['/opt/odoo/.local/share/Odoo/addons/8.0', u'/opt/odoo/openerp/addons', u'/opt/odoo/addons'] 2015-07-14 15:04:45,482 1184 INFO ? openerp: database hostname: localhost 2015-07-14 15:04:45,482 1184 INFO ? openerp: database port: 5432 2015-07-14 15:04:45,483 1184 INFO ? openerp: database user: odoo 2015-07-14 15:04:46,079 1184 INFO ? openerp.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069 2015-07-14 15:05:08,541 1184 INFO ? werkzeug: 105.237.210.67 - - [14/Jul/2015 15:05:08] "GET / HTTP/1.1" 500 - 2015-07-14 15:05:08,556 1184 ERROR ? werkzeug: Error on request: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi execute(self.server.app) File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute application_iter = app(environ, start_response) File "/opt/odoo/openerp/service/server.py", line 281, in app return self.app(e, s) File "/opt/odoo/openerp/service/wsgi_server.py", line 216, in application return application_unproxied(environ, start_response) File "/opt/odoo/openerp/service/wsgi_server.py", line 202, in application_unproxied result = handler(environ, start_response) File "/opt/odoo/openerp/http.py", line 1279, in __call__ self.load_addons() File "/opt/odoo/openerp/http.py", line 1298, in load_addons m = __import__('openerp.addons.' + module) File "/opt/odoo/openerp/modules/module.py", line 80, in load_module mod = imp.load_module('openerp.addons.' + module_part, f, path, descr) File "/opt/odoo/.local/share/Odoo/addons/8.0/auto_backup/__init__.py", line 23, in import backup_scheduler File "/opt/odoo/.local/share/Odoo/addons/8.0/auto_backup/backup_scheduler.py", line 33, in raise ImportError('This module needs pysftp to automaticly write backups to the FTP through SFTP. Please install pysftp on your system. (sudo pip install pysftp)') ImportError: This module needs pysftp to automaticly write backups to the FTP through SFTP. Please install pysftp on your system. (sudo pip install pysftp) pshttp

Dale
on 7/14/15, 11:06 AM

As the error saids Please install pysftp on your system. (sudo pip install pysftp)

Axel Mendoza
on 7/14/15, 2:03 PM
0
Dale
On 7/14/15, 11:25 AM

Hi All

I found the problem. It seems that another user installed an autobackup module which needed more work. I hadn't restarted the server in a very long time so when i  installed the new module and restarted i assumed the problem was with the new module. Thanks for all the input!


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 7/14/15, 4:41 AM
Seen: 1205 times
Last updated: 7/14/15, 11:25 AM