Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

menu icons and knowledge attachments aren't base64 encoded

By
veronika
on 6/5/13, 6:31 PM 908 views

I've migrated OpenERP database to another server. Import was completed successfully. But now menu web icons aren't displaying, and i can't open downloaded attachments from knowledge module. I launched debugger with some breakpoints on local machine and found out, that corresponding values (ir_ui_menu.web_icon_data) was returned as base64 encoded string, but on server they was returned just as binary data. so i tried to select values of this field in psql and saw the same binary data on my old server and current server, but when i run a simple python script using psycopg2 which did the same action, on my old server i get base64 encoded string, but on my current server i got just binary data. so, please explane me, what's matter with psycopg2 or what configuration is missing in postgres server.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 6/5/13, 6:31 PM
Seen: 908 times
Last updated: 3/16/15, 8:10 AM