Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

4

Live Chat (IM) bus.bus unavailable Exception

By
Carlos Vasquez
on 9/18/14, 1:58 PM 10,955 views

Hi,

In the latest v8.0 repo, when I install im_chat, the server starts logging errors like this:

2014-09-18 17:52:01,152 32356 ERROR tierrafirme openerp.http: Exception during JSON request handling.
Traceback (most recent call last):
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/http.py", line 499, in _handle_exception
    return super(JsonRequest, self)._handle_exception(exception)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/http.py", line 516, in dispatch
    result = self._call_function(**self.params)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/http.py", line 282, in _call_function
    return checked_call(self.db, *args, **kwargs)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/service/model.py", line 113, in wrapper
    return f(dbname, *args, **kwargs)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/http.py", line 279, in checked_call
    return self.endpoint(*a, **kw)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/http.py", line 732, in __call__
    return self.method(*args, **kw)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/openerp/http.py", line 375, in response_wrap
    response = f(*args, **kw)
  File "/srv/odoo/8.0/instances/tierrafirme/odoo/addons/bus/bus.py", line 188, in poll
    raise Exception("bus.Bus unavailable")
Exception: bus.Bus unavailable

 

Also the chat doesn't work properly, the messages do not arrive instantly, the chat windows do not close or minimize.

Is there something else I have to do to install or configure the bus or im_chat module?

Thanks

 

Hi Carlos, do you have the python-simplejson package installed on your machine? Please refer to the script here: https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh for a full list (to the best of my knowledge) of required packages for Odoo 8.0. I've used this script a number of times on a clean Ubuntu 14.04 install and have no problem running Odoo 8.0 in Gevent mode (for live chat). Please post back here with what you find to help any others encountering a similar issue.

Luke Branch
on 9/20/14, 12:37 AM

Hi Luke, thank you. I found a while ago that the problem is that I wasn't running the server on gevent mode.

ClearCorp S.A., Carlos Vasquez
on 9/20/14, 1:19 AM
3
Carlos Vasquez
On 10/12/14, 11:16 PM

Just to follow-up.

The answer is that I was not running the server in gevent mode. During 8.0 development odoo introduced gevent mode to be able to get real-time messages from one client to another. This had to be enabled running the server with the provided openerp-gevent script.

Now that the v8.0 is released, this was improved, you have to run the server with the odoo.py script, using the --workers option set with at least 2 workers, this way odoo will start that many workers, plus some cron workers and 1 gevent worker. This last one will take care of your bus and chat messages. To have a little more info about how to use regular workers with the gevent worker together read this other question.

Regards

2
Viktor Zhuromskyy
On 9/19/14, 11:49 PM

I've got same problem with 8.0 checked out today.

@Viktor, Are you running your odoo instance in openerp-gevent mode or openerp-server mode?

Luke Branch
on 9/30/14, 4:45 AM
in erpnext-server mode. After complete reinstalling looks loke its working now.

On 30/09/2014 3:45 AM, Luke wrote:
<blockquote cite="mid:1412066711.361253023147583.383049048831868-openerp-63279-forum.post@accounts.odoo.com" type="cite">

@Viktor, Are you running your odoo instance in openerp-gevent mode or openerp-server mode?

--
Luke
Sent by OpenERP S.A. using Odoo about Forum Post False
-- 
Best Regards,
Viktor Zhuromskyy
Viktor Zhuromskyy
on 9/30/14, 3:10 PM
2
Jean-Marc Dupont
On 9/30/14, 4:24 AM

Same for me

@Jean-Marc, Are you running your odoo instance in openerp-gevent mode or openerp-server mode?

Luke Branch
on 9/30/14, 4:44 AM

openerp-server mode

6 IT, Jean-Marc Dupont
on 9/30/14, 4:47 AM

@Jean-Marc, You need to run in openerp-gevent mode and you will not have this issue. I'd recommend using this script on a clean install of Ubuntu 14.04: https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh this will install with an auto-start script using openerp-gevent mode as default. Just go to a terminal and type the following: wget https://raw.githubusercontent.com/lukebranch/openerp-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh sudo sh odoo_install.sh and let the script run it's course. It'll finish and prompt you to restart and once you've restarted your odoo instance will be running in openerp-gevent mode.

Luke Branch
on 9/30/14, 4:55 AM
1
Ivan Yelizariev
On 6/18/16, 1:07 AM

Requests to /longpolling/ must be proxied to 8072 port:


location /longpolling {
    proxy_pass http://127.0.0.1:8072;
}
location / {
    proxy_pass http://127.0.0.1:8069;
}


https://odoo-development.readthedocs.io/en/latest/admin/longpolling.html


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 9/18/14, 1:58 PM
Seen: 10955 times
Last updated: 6/18/16, 1:07 AM