Odoo Help


"Leave Request To Approve": how to hide requests from other departments?

on 5/14/14, 12:21 PM 1,438 views

I configured departments, managers, employess but the managers can still see and approve requests from other department. How is possible to hide requests not relevant?

My OpenERP version is 7.0-20140410-231234 but I have the same problem with the online trial version (Version 7.saas~3). I create: Department1: Employee1 Boss1 (is manager in Department1 settings, and within Employee1 configuration menu as well) Department2: Employee2 Boss2 (is manager in Department2 settings, and within Employee2 configuration menu as well) Boss1 and Boss2 are HR officier I create a leave request for Employee1 and Employee2. *Results of menu "Leave Requests to Approve" open by the Boss1* *1) For the version (7.0-20140410-231234):* I see all requests. If I modify the filter adding "My Department Leaves" the list is *empty*. *2)  For Version 7.saas~3* I see al requests. If I modify the filter adding "My Department Leaves" the list contain all requests from *department2 (should be department1)*. *Is my setting wrong or there is a bug within the human resources module (department managment/leave requests)?*

on 6/11/14, 1:47 PM
Michael Telahun
On 5/18/14, 8:14 AM

Use hr_holidays_extension from https://launchpad.net/addons-hr-ng

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 5/14/14, 12:21 PM
Seen: 1438 times
Last updated: 3/16/15, 8:10 AM