Odoo Help

0

Jasper report not being attached

By
Odooveloper (by Rui Franco)
on 6/3/14, 7:46 AM 1,100 views

I've done everything the same way as in the "normal" RML reports but I can't get the jasper reports to become saved and attached to the records.

I've even redefined them (the reports) in the "jasper reports" option but to the same no result.

Is this a bug? Has anyone been able to create attachments out of jasper reports?

 

;)

0
Stefan Wailand
On 6/3/14, 8:16 AM

JasperReports works quite fine - even with attachments. Can you tell me what Odoo version you use and what JasperReports Addon?

0

Version: OpenERP 7

OS: Ubuntu 12.04.4 LTS

Addons: jasper_server (7.0.6.3), jasper_reports (7.0.0.1.1)

 

Here's a sample of a report definition:

<report
            auto="False"
            id="account.invoice2"
            model="account.invoice"
            name="account.invoice2"
            rml="xpto_invoice_report/report/xpto_invoice.jrxml"
            string="Invoices"
            attachment="(object.hash != False and ((object.name or '').replace('/','') + '.pdf'))"
            attachment_use="True"
            usage="default"
            menu="False"
            />

Cheers!

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 6/3/14, 7:46 AM
Seen: 1100 times
Last updated: 3/16/15, 8:10 AM