Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Issue with Translations

By
Juliano Henriquez
on 6/7/16, 2:01 AM 387 views

Have an Issue with my Odoo 9 install on Ubuntu 14.04, I've loaded around 40% of translations for es_DO ,  and translations where loading correctly 'till one day they stopped loading, and I've tried everything, deleting the terms directly on the Database (DELETE FROM ir_translation WHERE lang = 'es_DO';) , through the APP UI reloading terms, Synchronizing terms, (http://stackoverflow.com/questions/33475354/why-are-some-items-not-translated-in-odoo) and still no luck... Have also checked logs on info level and nothing fishy seems to come up, have tried playing around with limit_memory_hard, limit_memory_soft, limit_request, limit_time_cpu, limit_time_real, workers and no luck either, Any Idea what the issue could be?


Any help would be much appreciated. 

Have you tried updating your Odoo source code and then doing a -u all on the database to load in all .po files (which contain the translations) again?

Yenthe
on 6/7/16, 2:44 AM

Yes, Multiple time to no avail, didn't work.. Sadly...

Juliano Henriquez
on 6/7/16, 2:47 AM
0
Yousif Anwar
On 8/14/16, 1:21 PM

Will you please teach me how  and when to use this -u command so I can force translation to ignore the ir_translation table and reload from .po files.

I am really  new to odoo and want the easiest possible way to have it translated considering that  I may need to deploy it many times so I need to have some sort of translated po files - or what better if any - so I can replace them after any deployment. Many thanks!

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 6/7/16, 2:01 AM
Seen: 387 times
Last updated: 8/14/16, 1:21 PM