Odoo Help

0

issue when run openerp5 with parameter --update=all

By
paul
on 4/8/14, 7:31 PM 1,061 views

Hi, i hope all its fine , i want to ask you about this issue :

psycopg2.IntegrityError: duplicate key value violates unique constraint "res_groups_name_uniq"

DETAIL: Key (name)=(Finance / Accountant) already exists

sql:bad query: UPDATE "res_groups" SET "name"='Finance / Accountant',write_uid=1,write_date=now() WHERE id IN (49)

thats ocurs when i run my openerp server with parameter --update=all. I chage the database structure ON UPDATE NO ACTION, for ON UPDATE CASCADE on tables res_groups y ir_ui_menu_group_rel. The result its the same. The thing is Finance / Accountant = 49 on table res_groups,with constraint res_groups_name_uniq.

In res_group_id_seq the number its updated  start on 50, latter 51 when i run again  openerp-server.py  --config=/...rute/openerp-server.conf --update=all

regards.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 4/8/14, 7:31 PM
Seen: 1061 times
Last updated: 11/6/15, 4:57 PM