Odoo Help


Is webkit Invoice report working in openerp7 ?

Mohammad Zi
on 7/23/13, 11:55 PM 2,766 views


I have just now installed all required modules for webkit following the port in this forum to make the webkit run:

I receive below message when I try to open the sale order report generated by webkit.

callable_(context, args, *kwargs) File "memory:0x7f1ab8239f90", line 36, in render_body File "/opt/openerp/server/openerp/osv/orm.py", line 486, in __getattr__ raise AttributeError(e) AttributeError: "Field 'address' does not exist in object 'browse_record(res.partner, 1)'"

I have searched on the internet and found out that the address field is removed from the partner in openERP7 .Is this error message related to that one ?

Is related webkit module available for openERP 7 ?


Timo Talvitie, Vizucom Oy

--Timo Talvitie, Vizucom Oy--
| 5 4 7
Tampere, Finland
--Timo Talvitie, Vizucom Oy--

Lead developer at Vizucom.

Timo Talvitie, Vizucom Oy
On 7/26/13, 8:34 AM

We spent a while wondering this as well, and at least for us the problem was caused by the default header that the sale order webkit report is using.

The "Base Reports Portrait Header" header (provided by base_headers_webkit module) makes a reference to ${company.partner_id.address}, which seems to cause the issue.

As a workaround you can pick base_headers_webkit's header "Base Minimum Portrait Header" which does not include the address field. Not a perfect workaround, but at least you can get past the error and start to work on the actual reports.

You can replace the header by opening sale_order_webkit/sale_report.xml and changing the webkit_header parameter from webkit_header="base_headers_webkit.base_reports_portrait_header" to webkit_header="base_headers_webkit.base_minimum_reports_portrait_header"

The root cause is still somewhere else, though, since on another 7.0 installation also the default headers worked fine.

Thanks for your extensive reply

Mohammad Zi
on 8/5/13, 7:42 AM
Jakub Krzempek
On 12/3/13, 5:37 AM

Or you can create your own 'address' entity in the header file. Just use each of address fields exclusively, like:

${company.partner_id.street or ''|entity} ${company.partner_id.zip or ''|entity} ${company.partner_id.city or ''|entity} t: ${company.partner_id.phone or ''|entity} m: ${company.partner_id.email or ''|entity}

Of course you have put these in tr,td html's tags.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)


Asked: 7/23/13, 11:55 PM
Seen: 2766 times
Last updated: 3/16/15, 8:10 AM