Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Is there a way to deal with those bugs ?

By
NIcolas Plée
on 3/27/13, 4:35 PM 1,944 views

Hi, I noticed two bugs with contacts : 1/ Creating a new company, when I create a new contact linked to this company, I can save the new contact but I can't save the company having the following error :

 ValidateError
   The value "fr_CH" for the field "res_partner.lang" is not in the selection

When I first installed OpenERP, i may not have paid attention and the selected language was fr_CH. I then changed the language to fr_FR and deleted fr_CH.

2/ When I have a contact that is already created and link it to an existing company, most of the contact fields (actually all except name) are automatically replaced with the company info. I guess this is because Use company adress is checked automatically but I don't know how to set it up another way.

Do you know any way to resolve those stuffs ?

Thanks

1
Markku Luosto
On 3/28/13, 7:55 AM

I guess you can try to check the following things in your installation:

1) As an administrator, go to

  • Settings -> Technical -> Actions -> User-defined Defaults

Perhaps there is

1/ Name: lang, Model Name: res.partner, Value: fr_CH

2/ Name: use_parent_address, Model Name: res.partner, Value: 1

2) As an administrator, enable Developer mode

  1. Your Name (right upper corner) -> About OpenERP -> Developer mode
  2. Open the form for creating new contact.
  3. At the left upper corner open menu and choose "Set Defaults"
  4. At the dialog "Default" field you can see your defaults.

If you want to change the defaults, open empty contact form, change the desired value, open "Set Defaults" and choose the change you made and save it. Done.

The fields you are looking for are: - lang - use_parent_address

With best regards,

-make

thank you Markku for your answer. So here is what I get : 1) > 1/ Name: lang, Model Name: res.partner, Value: fr_CH Actually, if I try to change fr_CH for fr_FR, I get an automatic change of the field when I save it: S'fr_FR' p0 . It even gets more bizarre because I still have another installation running on another server and it doesn't happen when I change and save same field...

> 2/ Name: use_parent_address, Model Name: res.partner, Value: 1 I actually haven't this. Should I create it ?

NIcolas Plée
on 3/28/13, 2:48 PM

2) Actually, situation is also tricky on this... I can find "Use company Adress" in the Set Default list when it's checked. But when it's unchecked, it's just not there anymore...

NIcolas Plée
on 3/28/13, 2:51 PM

Settings -> Technical -> Actions -> User-defined Defaults

Perhaps there is

1/ Name: lang, Model Name: res.partner, Value: fr_CH

Yes that is !

Tuxservices, Jeudy Nicolas
on 9/11/13, 6:14 PM
0
NIcolas Plée
On 4/5/13, 2:15 PM

Ok so here are the news...

1/ Having no solution to resolve this, I decided to make a new installation. So now it's set up from the beginning as French.

2/ Still can't be changed the default value for "Use default company address".

So actually, I haven't clearly resolved anything but half of my problem is gone. Any suggestion for the second point ? Maybe I could change it directly in the database ? Any idea what would be the process ?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/27/13, 4:35 PM
Seen: 1944 times
Last updated: 3/16/15, 8:10 AM