Odoo Help

5
13 Answers
12
Aline Preillon (apr)
2/14/13, 10:48 AM

In Settings/Translations/Languages, you can change the date format for the language you use.

But you have to give technical features access to your admin user to see this menu.

Aline

3 Comments
omar bajunaid
3/11/13, 5:30 AM

This allows you to input the date in the chosen format. Upon saving , the display reverts to mm/dd/yyyy format. I tried this in HR. i do not know about the other modules. The field i tried was DOB.

patrick
5/13/13, 8:41 PM

The given procedure is working for me, even when I am using english as a language and the users have Dutch. I can change the format from mm/dd/yyyy to dd-mm-yyyy and they will see the date correctly.

Slim Bhiri
8/10/13, 1:04 AM

My admin and current user uses the French language and i must the English (which i think is the system language) date format language to see it applied in my invoices.

2
Avatar

tolstoj

--tolstoj--

1124
| 6 6 8
Germany
--tolstoj--

hi

tolstoj
2/14/13, 10:54 AM

in OpenERP backend:

settings -> translations -> languages -> choose your language to edit -> edit -> Date Format field
1 Comment
omar bajunaid
3/11/13, 5:31 AM

This allows you to input the date in the chosen format. Upon saving , the display reverts to mm/dd/yyyy format. I tried this in HR. i do not know about the other modules. The field i tried was DOB.

2
Avatar

Shameem Babu @ iWesabe

--Shameem Babu @ iWesabe--
GLOBAL CREATIVE CONCEPTS TECH CO LTD
http://www.iwesabe.com
1420
| 6 3 7
KHOBAR, Saudi Arabia
--Shameem Babu @ iWesabe--

  

 iWesabe - ODOO ERP IMPLEMENTATION & CUSTOMIZATION SAUDI ARABIA.



For Queries : pks.shameem@gmail.com ,shameem@iwesabe.com

Activities     :    Youtube

                           Stackoverflow 

Experience

           iWesabe                                ◉

           Axon Communications        ❍

           Cybrosys Technologies        ❍


Shameem Babu @ iWesabe
9/11/17, 1:12 AM

Through code ...

  <record id="base.lang_en" model="res.lang">
    <field name="date_format">%d-%b-%Y</field>
</record>
This is working in odoo 10..



2
Bill Ennals
5/13/13, 7:12 AM

I was also stuck with this. Changing the date format in the Settings/Translations/Languages seemed to have no effect (I even changed both the en_US and en_UK settings). Then I realised I hadn't changed the language setting in my own user preferences (top right hand corner -- User/Preferences/Lanuage). Select the language which you have changed the date format for and save.

This may not be the source of your problem but it may help someone else.

Bill.

0
swapnil trivedi
10/23/17, 2:51 AM

You can use http://bit.ly/2zIO8JN to change the date format. 

0
Oliver
9/12/16, 6:38 AM

...

0
dbvieira
8/29/14, 2:19 PM

I only have 

settings -> loading a translation
 

...

1 Comment
Oliver
9/12/16, 6:38 AM

You need to activate the developer mode, otherwise you won't see the extended menu.

Ask a Question
Tags
Keep Informed
0 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now