Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Is Aeroo report compatible with Odoo V8?

By
David Verove
on 2/6/15, 1:10 PM 2,510 views

Hello,

I've read in many forums problems are encountered with Aeroo report on V8, is there any comptaible and stable version that can be used ?

Thanks,

David

@David,

The official version 8.0 (beta) version is now available here:

https://github.com/aeroo/aeroo_reports.git#8.0
I haven't tried installing it yet, but it should work with the latest version of LibreOffice in Ubuntu 14.04.

Luke Branch
on 2/11/15, 4:24 AM

Hello, Thanks for the information. I have installed the modules and the libraries needed for aeroo, but I meet a problem with libreoffice server. It is started with command: ./soffice --nologo --nofirststartwizard --headless --norestore --invisible "--accept=socket,host=localhost,port=8100,tcpNoDelay=1;urp;" & I can see the job executing : root 28704 10073 0 15:52 pts/0 00:00:00 /usr/lib/libreoffice/program/oosplash --nologo --nofirststartwizard --headless --norestore --invisible --accept=socket,host=localhost,port=8100,tcpNo root 28718 28704 0 15:52 pts/0 00:00:00 /usr/lib/libreoffice/program/soffice.bin --nologo --nofirststartwizard --headless --norestore --invisible --accept=socket,host=localhost,port=8100,tc But I can't establish any connection from odoo (in Menu : Configure DOCS connection) : Failure! Connection to DOCS service was not established or convertion to PDF unsuccessful! Details HTTPConnectionPool(host='localhost', port=8100): Max retries exceeded with url: /

David Verove
on 2/26/15, 9:59 AM

I have the same problem. I tried Debian 7.0 with stock LibreOffice and Ubuntu 14.04 with a downgraded LibreOffice and OpenOffice.org. LibreOffice does respond to port 8100 however.

Mario Gielissen | Openworx
on 2/26/15, 10:06 AM

Hi All,

I've made a first draft for an installation method for Aeroo Reports for Odoo 8.0 on Ubuntu 14.04 here:

https://www.odoo.com/forum/help-1/question/solved-8-0-how-can-i-install-the-official-aeroo-reports-alistek-for-odoo-version-8-76044

Luke Branch
on 3/22/15, 11:45 PM
0
Juan José Scarafía
On 2/26/15, 11:32 AM

Hi David,

I have some problems with Aeroo too, but i have solved by changing the LibreOffice version, not the last. I have the version 1:4.3.3

Regards,

Juan José - Ing ADHOC

0
David Verove
On 3/4/15, 6:46 AM

Hi Juan José,

I finally succeeded to use libreoffice server with installing report_aeroo_ooo module.

But the odt given with the sample module always prints with odt extension, even when changing the aeroo report output mime-type.

I have this message in odoo's log : 

WARNING dev report_aeroo: PDF generator temporarily offline, please wait a minute

Did you have this message before downgrading Libreoffice?

Thanks,

David

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 2/6/15, 1:10 PM
Seen: 2510 times
Last updated: 3/22/15, 11:45 PM